HDU1530 Maximum Clique 最大团(最大完全子图)

http://acm.hdu.edu.cn/showproblem.php?pid=1530

Problem Description

Given a graph G(V, E), a clique is a sub-graph g(v, e), so that for all vertex pairs v1, v2 in v, there exists an edge (v1, v2) in e. Maximum clique is the clique that has maximum number of vertex.

 

 

Input

Input contains multiple tests. For each test:

The first line has one integer n, the number of vertex. (1 < n <= 50)

The following n lines has n 0 or 1 each, indicating whether an edge exists between i (line number) and j (column number).

A test with n = 0 signals the end of input. This test should not be processed.

 

 

Output

One number for each test, the number of vertex in maximum clique.

 

 

Sample Input

 

5 0 1 1 0 1 1 0 1 1 1 1 1 0 1 1 0 1 1 0 1 1 1 1 1 0 0

 

 

Sample Output

 

4

 

 

Author

CHENG, Long

 

 

Source

ZOJ Monthly, February 2003

 

 

Recommend

mcqsmall

 

 

#include<bits/stdc++.h>
#define N 1066
bool a[N][N];
int ans, cnt[N], group[N], n, m, vis[N];
bool dfs( int u, int pos )
{
    int i, j;
    for( i = u+1; i <= n; i++)//按递增顺序枚举顶点
    {
        if( cnt[i]+pos <= ans ) return 0;//剪枝
        if( a[u][i] )
        {
            // 与目前团中元素比较,取 Non-N(i)
            for( j = 0; j < pos; j++ ) if( !a[i][ vis[j] ] ) break;
            if( j == pos )
            {

                vis[pos] = i;
                if( dfs( i, pos+1 ) ) return 1;
            }
        }
    }
    if( pos > ans )
    {
        for( i = 0; i < pos; i++ )
            group[i] = vis[i]; // 更新最大团元素
        ans = pos;
        return 1;
    }
    return 0;
}
void maxclique()//求最大团
{
    ans=-1;
    for(int i=n; i>0; i--)
    {
        vis[0]=i;
        dfs(i,1);
        cnt[i]=ans;
    }
}
int main()
{
    int T;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        int x, y;
        memset( a, 0, sizeof(a));
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                scanf("%d",&a[i][j]);
        maxclique();
        if( ans < 0 ) ans = 0;
        printf("%d\n", ans );
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值