http://acm.hdu.edu.cn/showproblem.php?pid=1548
A strange liftTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 34037 Accepted Submission(s): 12153 Problem Description There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Input The input consists of several test cases.,Each test case contains two lines.
Output For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
Sample Input 5 1 5 3 3 1 2 5 0
Sample Output 3 |
#include<bits/stdc++.h>
using namespace std;
int n,b,e;
int num[206];
int vis[206];
struct node
{
int x;
int step;//结构体储存x和step数
};
bool check(int x)
{
if(x<=0||x>n)
{
return 1;
}
return 0;//定义check函数
}
int bfs()
{
queue<node> q;
node a,next;//定义两个node结构体
int i;
a.x=b;
a.step=0;
vis[b]=1;
q.push(a);//放入一个结构体
while(!q.empty())
{
a=q.front();
q.pop();//取出
if(a.x==e)
{
return a.step;
}//终点判断
for(int i=-1; i<=1; i+=2)
{
next=a;
next.x+=i*num[next.x];
if(check(next.x)||vis[next.x])
continue;
vis[next.x]=1;
next.step++;
q.push(next);
}//向上向下走
}
return -1;
}
int main()
{
int i,j;
while(~scanf("%d",&n),n)
{
scanf("%d%d",&b,&e);
for(i = 1; i<=n; i++)
scanf("%d",&num[i]);
memset(vis,0,sizeof(vis));
printf("%d\n",bfs());
}
return 0;
}