TRIE翻译明暗文HDU1075What Are You Talking About

http://acm.hdu.edu.cn/showproblem.php?pid=1075

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

 

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

 

Output

In this problem, you have to output the translation of the history book.

 

 

Sample Input

 

START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END

 

 

Sample Output

 
hello, i'm from mars. i like earth!

Hint

Huge input, scanf is recommended.
#include<iostream>
#include<string>
using namespace std;

struct trieNode{
    int count;//统计单词前缀出现的次数
    trieNode* next[26];//指向各子树的指针
    bool exit;//标记该结点处是否构成单词
    string traslate;//对应的译文

    trieNode() :count(0), exit(false){
        for (int i = 0; i < 26; i++){
            next[i] = NULL;
        }
    }
};


void trieInsert(trieNode* root, string &word, string &eng){
    trieNode *node = root;
    int id;
    int len = word.size();
    int i = 0;
    while (i < len){
        id = word[i] - 'a';
        if (node->next[id] == NULL){
            node->next[id] = new trieNode();
        }

        node = node->next[id];
        node->count += 1;

        i++;
    }
    node->exit = true;//单词结束,可以构成一个单词
    node->traslate = eng;//这里多一步操作,变成eng,也就是译文;
}

string trieSearch(trieNode*root, string &word){

    trieNode* node = root;
    int len = word.size();
    int i = 0;
    while (i < len){
        int id = word[i] - 'a';
        if (node->next[id] != NULL){
            node = node->next[id];
            i++;
        }
        else{
            return "";//不存在则返回空字符串;
        }
    }

    string res;
    if (node->exit){
        res = node->traslate;//如果有对应的译文,那么返回;
    }
    else{
        res = "";
    }

    return res;//如果exit为false,那么则返回空字符串;
}


int main()
{
    trieNode *root = new trieNode();

    string eng;
    string word;
    cin >> eng;
    while (cin >> eng && eng != "END"){
        cin >> word;
        trieInsert(root, word, eng);
    }

    cin.get();//去掉上一行的换行符

    while (getline(cin, word)){//一个个输入

        if (word == "START"){
            continue;
        }

        if (word == "END"){
            break;
        }
        string tmpWord = "";
        int len = word.size();

        for (int i = 0; i < len; i++){//一个个字符判断;
            if (word[i] >= 'a' && word[i] <= 'z'){
                tmpWord += word[i];
            }
            else{//主要是为了判断标点符号问题;
                string res = trieSearch(root, tmpWord);
                if (!res.empty()){
                    cout << res;
                }
                else{
                    cout << tmpWord;
                }
                cout << word[i];
                tmpWord = "";
            }
        }

        cout << endl;
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值