POJ3067 Japan树状数组+逆序数

http://poj.org/problem?id=3067

将Y坐标从小到大排序,Y值相同则按X从小到大排序;
就是求X的逆序数之和,但是要注意逆序数的求法;

Japan

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33883 Accepted: 9074

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAXN=1000;
const int MAXM=1000000+1000;
int c[MAXN+1];//c[0]是无效的
struct node
{
    int x,y;
    bool operator <(const node &b)const
    {
        return y<b.y||( y==b.y&&x<b.x );
    }
} nodes[MAXM];
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res +=c[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int x,int v)
{
    while(x<=MAXN)
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0; i<k; i++)
            scanf("%d%d",&nodes[i].x,&nodes[i].y);
        sort(nodes,nodes+k);
        memset(c,0,sizeof(c));
        long long ans=0;
        for(int i=0; i<k; i++)
        {
            add(nodes[i].x,1);
            ans += sum(MAXN)-sum(nodes[i].x);//累加逆序
            //在它前面都是比较小的数,所以SUM(MAXN)-SUM...就是逆序数;
        }
        printf("Test case %d: %I64d\n",kase++,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值