HDU2054 A==B? 情况考虑完全

http://acm.hdu.edu.cn/showproblem.php?pid=2054

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B. 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO
#include<bits/stdc++.h>
using namespace std;
char a[1000000],b[1000000];
void init(char a[])
{
    int flag=0;
    for(int i=strlen(a)-1; i>=0; i--)
    {
        if(a[i]=='.')
        {
            flag=i;
            break;
        }
    }
    if(flag)
    {
        for(int i=strlen(a)-1; i>0; i--)
        {
            if(a[i]=='0')
            {
                a[i]='\0';
            }
            else
            {
                if(a[i]=='.'){
                    a[i]='\0';
                }
                break;
            }
        }
    }
}
int main()
{
    while(cin>>a>>b)
    {

        init(a);
        init(b);
        //cout<<a<<b<<endl;

        if(strlen(a)!=strlen(b)){
            cout<<"NO"<<endl;
            continue;
        }else{
            int flag=0;
            for(int i=0;i<strlen(a);i++){
                if(a[i]!=b[i])flag=1;
            }
            if(!flag){
                cout<<"YES"<<endl;
            }else{
                cout<<"NO"<<endl;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值