差分约束+判断负环

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N(0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable
  • 给出若是p,那么加两次边。
  • if(c[0]=='P')
  •             {
  •                 scanf("%d%d%d",&u,&v,&w);//u-v=w则u-v<=w v-u<=w,
  •                 add_edge(v,u,w);
  •                 add_edge(u,v,-w);
  •             }
  •             else
  •             {
  •                 scanf("%d%d",&u,&v);//u-v>=1->v-u<=-1;
  •                 add_edge(u,v,-1);
  •             }
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
struct Node
{
    int u;
    int v;
    int w;
    int next;
} s[210000];
int head[1010];
int dist[1010];
bool vis[1010];
int n,m,num;
int coun[1010];
void add_edge(int a,int b,int c)
{
    s[num].u = a;
    s[num].v = b;
    s[num].w = c;
    s[num].next = head[a];
    head[a] = num++;
}
int SPFA()
{
    queue<int> Q;
    memset(dist,inf,sizeof(dist));
    memset(vis,false,sizeof(vis));
    memset(coun,0,sizeof(coun));
    dist[0] = 0;
    vis[0] = true;
    coun[0] = 1;
    Q.push(0);
    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        coun[u]++;
        if(coun[u]>n)//记录这个点进入队列的次数,不符合直接return 0
        {
            return 0;
        }
        for(int i=head[u]; i!=-1; i=s[i].next)
        {
            int v = s[i].v;
            int w = s[i].w;
            if(dist[v]>dist[u]+w)
            {
                dist[v] = dist[u] + w;
                if(!vis[v])
                {
                    vis[v] = true;
                    Q.push(v);
                }
            }
        }
    }
    return 1;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        num = 0;
        int i,j;
        char c[2];
        int u,v,w;
        memset(head,-1,sizeof(head));
        while(m--)
        {
            scanf("%s",c);
            if(c[0]=='P')
            {
                scanf("%d%d%d",&u,&v,&w);//u-v=w则u-v<=w v-u<=w,
                add_edge(v,u,w);
                add_edge(u,v,-w);
            }
            else
            {
                scanf("%d%d",&u,&v);//u-v>=1->v-u<=-1;
                add_edge(u,v,-1);
            }
        }
        for(i=1; i<=n; i++)
        {
            add_edge(0,i,0); //找一个超级源点,给所有点都有关系,权值为0
        }
        if(SPFA())
        {
            printf("Reliable\n");
        }
        else
        {
            printf("Unreliable\n");
        }

    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值