2019山东省赛Median(Floyd传递闭包)

Recall the definition of the median of  elements where  is odd: sort these elements and the median is the -th largest element.

In this problem, the exact value of each element is not given, but  relations between some pair of elements are given. The -th relation can be described as , which indicates that the -th element is strictly larger than the -th element.

For all , is it possible to assign values to each element so that all the relations are satisfied and the -th element is the median of the  elements?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers  and  (, ), indicating the number of elements and the number of relations. It's guaranteed that is odd.

For the following  lines, the -th line contains two integers  and , indicating that the -th element is strictly larger than the -th element. It guaranteed that for all ,  or .

It's guaranteed that the sum of  of all test cases will not exceed .

Output

For each test case output one line containing one string of length . If it is possible to assign values to each element so that all the relations are satisfied and the -th element is the median, the -th character of the string should be '1', otherwise it should be '0'.

Sample Input

2
5 4
1 2
3 2
2 4
2 5
3 2
1 1
2 3

Sample Output

01000 000

Hint

For the first sample test case, as the 2nd element is smaller than the 1st and the 3rd elements and is larger than the 4th and the 5th elements, it's possible that the 2nd element is the median.

For the second sample test case, as the 1st element can't be larger than itself, it's impossible to assign values to the elements so that all the relations are satisfied.


Author: WANG, Yucheng

 

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100+10;
int mp[maxn][maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int flag=0;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                mp[i][j]= 0;
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            if(u==v)
                flag=1;
            mp[u][v]=1;
        }
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    mp[i][j] |=mp[i][k]&mp[k][j];
        int in[maxn],out[maxn];
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(mp[i][j]==1&&mp[j][i]==1)
                    flag=1;

        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(i!=j&&mp[i][j])
                {
                    ++in[j],++out[i];
                }
        int ans=0;
        if(flag)
        {
            for(int i=1; i<=n; i++)
                printf("0");
            printf("\n");
            continue;
        }
        for(int i=1; i<=n; i++)
            if((in[i]>(n)/2 ||out[i]>(n)/2))
            {
                printf("0");
            }
            else
            {
                printf("1");
            }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值