2019ACM山东省赛L题 Median/ZOJ 4124(传递闭包)

题目链接:

     http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=4124

 

题目描述:

Median

Time Limit: 1 Second      Memory Limit: 65536 KB

Recall the definition of the median of  elements where  is odd: sort these elements and the median is the -th largest element.

In this problem, the exact value of each element is not given, but  relations between some pair of elements are given. The -th relation can be described as , which indicates that the -th element is strictly larger than the -th element.

For all , is it possible to assign values to each element so that all the relations are satisfied and the -th element is the median of the  elements?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers  and  (, ), indicating the number of elements and the number of relations. It's guaranteed that  is odd.

For the following  lines, the -th line contains two integers  and , indicating that the -th element is strictly larger than the -th element. It guaranteed that for all ,  or .

It's guaranteed that the sum of  of all test cases will not exceed .

Output

For each test case output one line containing one string of length . If it is possible to assign values to each element so that all the relations are satisfied and the -th element is the median, the -th character of the string should be '1', otherwise it should be '0'。

Sample Input

2
5 4
1 2
3 2
2 4
2 5
3 2
1 1
2 3

Sample Output

01000 

000

Hint

For the first sample test case, as the 2nd element is smaller than the 1st and the 3rd elements and is larger than the 4th and the 5th elements, it's possible that the 2nd element is the median.

For the second sample test case, as the 1st element can't be larger than itself, it's impossible to assign values to the elements so that all the relations are satisfied.

题目描述:

          T组样例,n个数据1~n,m组关系描述这n个数的大小关系,问根据这m组关系,1~n中有哪些数可能为中位数。

思路:

        题目要求的是可能为中位数的数,考虑如果某数不为中位数,那么小于它的数或者大于它的数的个数一定>=(n+1)/2,所以可以处理出所有数之间的关系矩阵,进而根据入度出度判断;同时又因为小于关系满足传递性,所以可以用floyed闭包的方法求解矩阵。

代码实现:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100+10;
int mp[maxn][maxn];
int in[maxn],out[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                mp[i][j]=0;
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            mp[u][v]=1;
        }
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    mp[i][j] |=mp[i][k]&mp[k][j];

        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        bool f=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(mp[i][j])
                {
                    if(i==j)
                    {
                        f=1;
                        break;
                    }
                    ++in[j],++out[i];
                }
            }
            if(f)break;
        }
        if(f)
        {
            for(int i=1; i<n; ++i)printf("0");
            printf("0\n");
            continue;
        }
        for(int i=1; i<=n; i++)
        {
            if(in[i]>=(n+1)/2 || out[i]>=(n+1)/2)printf("0");
            else printf("1");
        }
        printf("\n");
    }
    return 0;
}

    

遗憾!!!

 

 



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值