【322 sort 归并排序】

Sort

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of T number of test cases.(<0T<1000) Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
2
3
1 2 3
4
4 3 2 1
样例输出
0
6
/*归并排序,记录交换的次数
在a[i]>a[j]  需要交换的次数就为  mid-i+1
*/

#include<cstdio>
int a[100005],temp[100005];
int memgesort(int a[],int first,int mid,int last){
    int i=first,j=mid+1,n=mid,m=last,s=first,count=0;
    while(i<=n&& j<=m){
        if(a[i]<=a[j])
            temp[s++]=a[i++];
        else{
            temp[s++]=a[j++];
            count+=(mid-i+1);
        }
    }
    while(i<=n)
        temp[s++]=a[i++];
    while(j<=m)
        temp[s++]=a[j++];
    for(int i=first;i<=last;i++)
        a[i]=temp[i];
    return count;
}
int memsort(int a[],int first,int last){
    int mid=(first+last)/2;
    int x,y,z;
    if(first>=last)
        return 0;
    x=memsort(a,first,mid);
    y=memsort(a,mid+1,last);
    z=memgesort(a,first,mid,last);
    return (x+y+z);
}
int main(){
    int m,n;
    scanf("%d",&m);
    while(m--){
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
    printf("%d\n",memsort(a,0,n-1));
    }
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

paidream

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值