233 Sort it【模拟】

Sort it

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
3
1 2 3
4 
4 3 2 1 
样例输出
0
6


冒泡排序的全过程,只能全程模拟了....注意交换的情况...

两个数组,一个保存排序完成的状态,一个是起始状态,循环查找,交换,模拟冒泡

比较简单...


#include<stdio.h>
#include<algorithm>
using namespace std;
int n,a[10005],b[10005];
void change(int x,int y)//交换
{
	int tp;
	tp=b[x];b[x]=b[y];b[y]=tp;
}
int search(int l,int r,int x)//查找这个值的位置
{
	for(int i=l;i<r;++i)
	{
		if(b[i]==x)
		{
			return i;
		}
	}
}
void slove()
{
	int cnt=0;
	for(int i=0;i<n;++i)
	{
		if(a[i]!=b[i])
		{
			int tp=search(i,n,a[i]);
			for(int j=tp;j>i;--j)//模仿冒泡,全程交换
			{
				change(j,j-1);
				++cnt;
			}
		}
	}
	printf("%d\n",cnt);
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			int tp;
			scanf("%d",&tp);
			a[i]=b[i]=tp;//两个数组,比较方便
		}
		sort(a,a+n);
		slove();
	}
	return 0;
}


到今天才想明白,原来是求逆序数的,然后自己只会最直接暴力的方法,双循环枚举....(2015.0919)


#include<stdio.h>
int main()
{
	int x[1005],n;
	while(~scanf("%d",&n))
	{	
		for(int i=0;i<n;++i)
		{
			scanf("%d",x+i);
		}
		int cnt=0;
		for(int  i=0;i<n;++i)
		{
			for(int j=i+1;j<n;++j)
			{
				if(x[j]<x[i])
				{
					++cnt;
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值