有趣的编码累加问题 Encoding 【水】

6 篇文章 0 订阅
5 篇文章 0 订阅

Encoding

Time Limit: 1 Sec   Memory Limit: 32 MB
Submit: 23   Solved: 8
[ Submit][ Status][ Web Board]

Description

Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C

HINT

Source



#include <stdio.h>
#include <iostream>
using namespace std;
const int MAX = 10001;

int main()
{
	int n;
	int i,j;
	char x[MAX];
	char c;
	
	while(~scanf("%d",&n))
	{
		while ( n-- )
		{
			cin >> x;
			i = 0,  j = 1;
			while( x[i] != '\0')
			{
				if ( x[i] == x[ i + 1])
				{
					j++;
					i++;

				}
				else 
				{
					
					c = x[i];
					if ( j == 1)
					{
							cout << c;
							i++;
							 
					}
					
					else 
					{
					 
						cout << j;
						cout << c;
						i++;
						j = 1;
					} 
				}
				
			} 
			cout << endl;
			
			
		}
			
	
	}
		
		
		return 0;
}

这么水的题目 居然上传错了几次 什么鬼。。。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值