最长上升子序列 O(nlogn)

5 篇文章 0 订阅

https://oj.jdfz.com.cn/oldoj/problem.php?id=2157

2157: Increasing
Description
数列A1,A2,……,AN,修改最少的数字,使得数列严格单调递增。

Input
第1 行,1 个整数N
第2 行,N 个整数A1,A2,……,AN

Output
1 个整数,表示最少修改的数字

Sample Input
3
1 3 2

Sample Output
1

HINT
• 对于50% 的数据,N <= 10^3
• 对于100% 的数据,1 <= N <= 10^5, 1 <= Ai <= 10^9

/*
b[pos] 代表长度为 pos 的 最长上升子序列 的 最后一个数的最小值
可知 b[ ] 为单调递增的
于是 upper_bound 二分 一下
*/

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n;
int a[100005];
int b[100005],cnt;
int main()
{
    scanf("%d",&n);
    int i,j;
    for(i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
    }
    b[1]=a[1];
    cnt=1;
    for(i=1;i<=n;i++)
    {
        if(a[i]>b[cnt]) b[++cnt]=a[i];
        else
        {
            int pos=upper_bound(b+1,b+cnt+1,a[i])-b;
            b[pos]=a[i];
        }
    }
    printf("%d",n-cnt);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值