hd 2123 An easy problem

 <h1 style="COLOR: #1a5cc8">An easy problem</h1><span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;FONT-WEIGHT: bold">Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5346    Accepted Submission(s): 3723
</span></strong></span>

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the i<sup>th</sup> row and j<sup>th</sup> column should be the product(乘积) of i and j.</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">For each test case, print out the multiply table.
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="FONT-FAMILY: Courier New,Courier,monospace">2
1
4</div>
 

Sample Output
  
  
1 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16
Hint
There is no blank space at the end of each line.
 

Author
XHD
 

Source
 

 
 
#include<stdio.h>
int main()
{
    int t,n,i,j;
    while(scanf("%d",&t)!=EOF)
    {
      while(t--)
      {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
         if(j!=n)
         printf("%d ",i*j);
         else
         printf("%d\n",i*j);
                         }
                }
                              }
return 0;    
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值