我的第一次编程

1.题目描述

Beinga nonconformist, Volodya is displeased with the current state of things,particularly with the order of natural numbers (natural number is positiveinteger number). He is determined to rearrange them. But there are too manynatural numbers, so Volodya decided to start with the first n. He writes downthe following sequence of numbers: firstly all odd integers from 1 to n (inascending order), then all even

integersfrom 1 to n (also in ascending order). Help our hero to find out which numberwill stand at the position number k.

Input

Theonly line of input contains integers n and k (1≤k≤n≤1e14).  

Output

Printthe number that will stand at the position number k after Volodya'smanipulations.  

Sampletest(s) input
10 3

77

output

5

6

Note

In thefirst sample Volodya's sequence will look like this: {1, 3, 5, 7, 9, 2, 4, 6,8, 10}. The third place in the sequence is therefore occupied by the number 5.

Hint

注意数据的类型

use__int64 to read data and use %I64d to output data 

输入格式

The onlyline of input contains integers n and k (1≤k≤n≤1e14).  

输出

Printthe number that will stand at the position number k after Volodya'smanipulations.  

样例输入

10 3
7 7

样例输出

5
6

代码如下:

 

 

#include<iostream>

using namespace std;

 

int main(void)

{

         longlong n,k;

         while(cin>>n>>k)

         {

                   longlong Result=0;

                   if(n%2==0)

                   {

                            if(k<=n/2)

                            {

                                     Result=2*k-1;

                            }

                            else

                            {

                                     Result=2*k-n;

                            }

                            cout<<Result<<endl;

                   }

                   else

                   {

                            if(k<=n/2+1)

                            {

                                     Result=2*k-1;

                            }

                            else

                            {

                                     Result=2*k-n-1;

                            }

                            cout<<Result<<endl;

                   }

         }

         return0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,下面是一个简单的 MapReduce 编程实例: 假设我们有一个文本文件,其中每一行是一个单词。我们想要对这些单词进行计数,并且按照出现次数从大到小进行排序。 首先,我们需要编写 Map 函数,将每个单词映射到一个键值对。键是单词本身,值是 1(表示出现了一次): ```python def map_function(line): words = line.strip().split() for word in words: yield word, 1 ``` 然后,我们需要编写 Reduce 函数,将相同单词的计数相加: ```python def reduce_function(word, counts): yield word, sum(counts) ``` 最后,我们可以使用 Hadoop MapReduce 框架来执行这个程序,其中输入数据是一个文本文件,输出数据是一个按照单词出现次数排序的列表: ```python from mrjob.job import MRJob from mrjob.step import MRStep class WordCount(MRJob): def steps(self): return [ MRStep(mapper=self.map_function, reducer=self.reduce_function), MRStep(reducer=self.reduce_sort) ] def map_function(self, _, line): words = line.strip().split() for word in words: yield word, 1 def reduce_function(self, word, counts): yield word, sum(counts) def reduce_sort(self, word, counts): yield None, (sum(counts), word) def reducer_final(self, _, word_counts): for count, word in sorted(word_counts, reverse=True): yield word, count if __name__ == '__main__': WordCount.run() ``` 这个程序使用两个 MapReduce 步骤。第一个步骤是对每个单词计数,第二个步骤是对计数进行排序。 这只是一个简单的例子,实际的 MapReduce 程序可能更加复杂。但是,这个例子可以帮助你理解 MapReduce 的基本思想和编程模型。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值