南华大学ACM第一场个人联系赛 A Eming

Eming

   

   Eming is a contest hold by WHUACM training team. The aim is to select new members of the team.

   Usually, the first problem is a very simple problem such as “a+b problem”. But this time, Xioumu is tired of this kind of problem, he decide to solve “a and b problem”.

   Give you the result of a + b and a^2 – b^2, please output the result of a and b.

 

   Input

   There are several test cases. For each case there are two double numbers indicating a+b and a^2-b^2. You may assume that a+b will not be zero.

 

   Output

   For each case please output the result of a and b in one line, rounded to 2 decimal places.

 

   Sample Input

   3 -3

 

   Sample Output

   1.00 2.00

 

仔细读懂题意,题目说要求两个浮点数,且告诉了你两个数的和及两个数的平方差,即(a+b,和a^2-b^2),那么这个可以用解方程组的方法来解决,假设m=a+b,n=a^2-b^2,则可以解得a=(m+n/m)/2,,b=(m-n/m)/2.然后就是保留两个小数就好了。

下面是我的代码:

#include<iostream>
#include<iomanip>
using namespace std;

int main()
{
    double m,n;
    double a,b;
    while(cin>>m>>n)
    {
        a=(m+n/m)/2;
        b=(m-n/m)/2;
        cout<<setprecision(2)<<fixed<<a<<" "<<b<<endl;
    }
    return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值