Strings of Power

Volodya likes listening to heavy metal and (occasionally) reading. No wonder

Volodya is especially interested in texts concerning his favourite music style.

Volodya calls a string powerful if it starts with "heavy" and ends with "metal". Finding all powerful substrings (by substring Volodya means a subsequence of consecutive characters in a string) in a given text makes our hero especially joyful. Recently he felt an enormous fit of energy while reading a certain text. So Volodya decided to count all powerful substrings in this text and brag about it all day long. Help him in this difficult task. Two substrings are considered different if they appear at the different positions in the text.

For simplicity, let us assume that Volodya's text can be represented as a single string. 




输入格式

Input contains a single non-empty string consisting of the lowercase Latin alphabet letters. Length of this string will not be greater than 1e6 characters. 

输出

Print exactly one number — the number of powerful substrings of the given string. 

样例输入

heavymetalisheavymetal
heavymetalismetal
trueheavymetalissotruewellitisalsosoheavythatyoucanalmostfeeltheweightofmetalonyou

样例输出

3
2
3

 

我觉得这道题只要一直搜索下去就好了。

代码如下:

#include<iostream>
#include<cstring>
using namespace std;

const int MAXN=1000010;
char str[MAXN];
int main(void)
{
 memset(str,0,sizeof(str));
 int i;
 while(cin>>str)
 {
  int len=strlen(str);
  int sum=0;
  int count=0;
  for(i=0;i<len;i++)
  {
   if(str[i]=='h'&&str[i+1]=='e'&&str[i+2]=='a'&&str[i+3]=='v'&&str[i+4]=='y')
   {
    i+=4;
    count++;
   }
   else if(str[i]=='m'&&str[i+1]=='e'&&str[i+2]=='t'&&str[i+3]=='a'&&str[i+4]=='l')
   {
    i+=4;
    sum=sum+count;
   }
  }
  cout<<sum<<endl;
  memset(str,0,sizeof(str));
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值