神州数码交换机配置基本命令

神州数码交换机配置基本命令
交换机基本状态:
hostname> ;用户模式
hostname# ;特权模式
hostname(config)# ;全局配置模式
hostname(config-if)# ;接口状态
交换机口令设置:
switch>enable ;进入特权模式
switch#config terminal ;进入全局配置模式
switch(config)#hostname ;设置交换机的主机名
switch(config)#enable secret xxx ;设置特权加密口令
switch(config)#enable password xxa ;设置特权非密口令
switch(config)#line console 0 ;进入控制台口
switch(config-line)#line vty 0 4 ;进入虚拟终端
switch(config-line)#login ;允许登录
switch(config-line)#password xx ;设置登录口令 xx
switch#exit ;返回命令
交换机 VLAN 设置:
switch#vlan database ;进入 VLAN 设置
switch(vlan)#vlan 2 ;建 VLAN 2
switch(vlan)#no vlan 2 ;删 vlan 2
switch(config)#int f0/1 ;进入端口 1
switch(config-if)#switchport access vlan 2 ;当前端口加入 vlan 2
switch(config-if)#switchport mode trunk ;设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的 vlan
switch(config-if)#switchport trunk encap dot1q ;设置 vlan 中继
switch(config)#vtp domain ;设置发 vtp 域名
switch(config)#vtp password ;设置发 vtp 密码
switch(config)#vtp mode server ;设置发 vtp 模式
switch(config)#vtp mode client ;设置发 vtp 模式
交换机设置 IP 地址:
switch(config)#interface vlan 1 ;进入 vlan 1
switch(config-if)#ip address ;设置 IP 地址
switch(config)#ip default-gateway ;设置默认网关
switch#dir Flash: ;查看闪存
交换机显示命令:
switch#write ;保存配置信息
switch#show vtp ;查看 vtp 配置信息
switch#show run ;查看当前配置信息
switch#show vlan ;查看 vlan 配置信息
switch#show interface ;查看端口信息
switch#show int f0/0 ;查看指定端口信息
完了最最要的一步。要记得保存设置俄,
保存命令:switch(config)#copy running-config startup-config
VLAN 配置命令

神州数码交换机配置基本命令

9.2.2.1 vlan
命令:vlan [vlan-id]
no vlan [vlan-id]
功能:创建 vlan 并且进入 vlan 配置模式,在 vlan 模式中,用户可以配置 vlan 名称和
为该 vlan 分配交换机端口;本命令的 no 操作为删除指定的 vlan。
参数:[vlan-id]为要创建/删除的 vlan 的 vid,取值范围为 1~4094。
命令模式:全局配置模式
缺省情况:交换机缺省只有 vlan1。
使用指南:vlan1 为交换机的缺省 vlan,用户不能配置和删除 vlan1。允许配置 vlan 的 总共数量为 255 个。另需要提醒的是不能使用本命令删除通过 gvrp 学习到的动态 vlan。
举例:创建 vlan100,并且进入 vlan100 的配置模式。
switch(config)#vlan 100
switch(config-vlan100)#
9.2.2.2 name
命令:name [vlan-name]
no name
功能:为 vlan 指定名称,vlan 的名称是对该 vlan 一个描述性字符串;本命令的 no 操 作为删除 vlan 的名称。
参数:[vlan-name]为指定的 vlan 名称字符串。
命令模式:vlan 配置模式
缺省情况:vlan 缺省 vlan 名称为 vlanxxx,其中 xxx 为 vid。
使用指南:交换机提供为不同的 vlan 指定名称的功能,有助于用户记忆 vlan,方便管
理。
举例:为 vlan100 指定名称为 testvlan。
switch(config-vlan100)#name testvlan
9.2.2.3 switchport access vlan
命令:switchport access vlan [vlan-id]
no switchport access vlan
功能:将当前 access 端口加入到指定 vlan;本命令 no 操作为将当前端口从 vlan 里删 除。
参数:[vlan-id]为当前端口要加入的 vlan vid,取值范围为 1~4094。
命令模式:端口配置模式
缺省情况:所有端口默认属于 vlan1。
使用指南:只有属于 access mode 的端口才能加入到指定的 vlan 中,并且 access 端口
同时只能加入到一个 vlan 里去。
举例:设置某 access 端口加入 vlan100。
switch(config)#interface ethernet 0/0/8
switch(config-ethernet0/0/8)#switchport mode access
switch(config-ethernet0/0/8)#switchport access vlan 100
switch(config-ethernet0/0/8)#exit
9.2.2.4 switchport interface
命令:switchport interface [interface-list]
no switchport interface [interface-list]
功能:给 vlan 分配以太网端口的命令;本命令的 no 操作为删除指定 vlan 内的一个或
一组端口。
参数:[interface-list] 要添加或者删除的端口的列表,支持”;””-”,如:ethernet 0/0/1;2;5
神州数码交换机配置基本命令
或 ethernet 0/0/1-6;8。
命令模式:vlan 配置模式
缺省情况:新建立的 vlan 缺省不包含任何端口。
使用指南:access 端口为普通端口,可以加入 vlan,但同时只允许加入一个 vlan。
举例:为 vlan100 分配百兆以太网端口 1,3,4-7,8。
switch(config-vlan100)#switchport interface ethernet 0/0/1;3;4-7;8

9.2.2.5 switchport mode
命令:switchport mode {trunk|access}
功能:设置交换机的端口为 access 模式或者 trunk 模式。
命令模式:端口配置模式
参数:trunk 表示端口允许通过多个 vlan 的流量;access 为端口只能属于一个 vlan。
命令模式:端口配置模式
缺省情况:端口缺省为 access 模式。
使用指南:工作在 trunk mode 下的端口称为 trunk 端口,trunk 端口可以通过多个 vlan
的流量,通过 trunk 端口之间的互联,可以实现不同交换机上的相同 vlan 的互通;工作在
access mode 下的端口称为 access 端口,access 端口可以分配给一个 vlan,并且同时只能分 配给一个 vlan。
在 trunk 端口不允许 802.1x 认证。
举例:将端口 5 设置为 trunk 模式,端口 8 设置为 access 模式。
switch(config)#interface ethernet 0/0/5
switch(config-ethernet0/0/5)#switchport mode trunk
switch(config-ethernet0/0/5)#exit
switch(config)#interface ethernet 0/0/8
switch(config-ethernet0/0/8)#switchport mode access
switch(config-ethernet0/0/8)#exit
9.2.2.6 switchport trunk allowed vlan
命令:switchport trunk allowed vlan {[vlan-list]|all}
no switchport trunk allowed vlan
功能:设置 trunk 端口允许通过 vlan;本命令的 no 操作为恢复缺省情况。
参数:[vlan-list]为允许在该 trunk 端口上通过的 vlan 列表;all 示关键字表允许该 trunk
端口通过所有 vlan 的流量。
命令模式:端口配置模式
缺省情况:trunk 端口缺省允许通过所有 vlan。
使用指南:用户可以通过本命令设置哪些 vlan 的流量通过 trunk 端口,没有包含的 vlan
流量则被禁止。
举例:设置 trunk 端口允许通过 vlan1,3,5-20 的流量。
switch(config)#interface ethernet 0/0/5
switch(config-ethernet0/0/5)#switchport mode trunk
switch(config-ethernet0/0/5)#switchport trunk allowed vlan 1;3;5-20
switch(config-ethernet0/0/5)#exit
9.2.2.7 switchport trunk native vlan
命令:switchport trunk native vlan [vlan-id]
no switchport trunk native vlan
功能:设置 trunk 端口的 pvid;本命令的 no 操作为恢复缺省值。
参数:[vlan-id]为 trunk 端口的 pvid。
命令模式:端口配置模式

神州数码交换机配置基本命令

缺省情况:trunk 端口默认的 pvid 为 1。
使用指南:在 802.1q 中定义了 pvid 这个概念。trunk 端口的 pvid 的作用是当一个
untagged 的帧进入 trunk 端口,端口会对这个 untagged 帧打上带有本命令设置的 native pvid
的 tag 标记,用于 vlan 的转发。
举例:设置某 trunk 端口的 native vlan 为 100。
switch(config)#interface ethernet 0/0/5
switch(config-ethernet0/0/5)#switchport mode trunk
switch(config-ethernet0/0/5)#switchport trunk native vlan 100
switch(config-ethernet0/0/5)#exit
9.2.2.8 vlan ingress enable
命令:vlan ingress enable
no vlan ingress enable
命令模式:端口配置模式
功能:打开端口的 vlan 入口规则;本命令的 no 操作为关闭入口准则。
缺省情况:系统缺省关闭端口的 vlan 入口准则。
使用指南:当打开端口的 vlan 入口规则,系统在接收数据时会检查源端口是否是该 vlan
的成员端口,如果是则接受数据并转发到目的端口,否则丢弃该数据。
举例:打开端口的 vlan 入口规则。
switch(config-ethernet0/0/1)# vlan ingress enable
9.2.2.9 private-vlan
命令:private-vlan {primary|isolated|community}
no private-vlan
功能:将当前 vlan 设置为 private vlan,该命令的 no 操作为取消 private vlan 设置。
参数:primary 将当前 vlan 设置为 primary vlan,isolated 将当前 vlan 设置为 isolated
vlan,community 将当前 vlan 设置为 community vlan。
命令模式:vlan 配置模式
缺省情况:缺省没有 private vlan 配置。
使用指南:private vlan 分为三种:primary vlan,在 primary vlan 内的端口可以和关 vlan, 在 isolated vlan 内的端口之间是隔绝的,它们只可以和其相关联的 primary vlan 内的端口通
信;community vlan,在 community vlan 内的端口相互之间可以通信,也可以和其相关联的
primary vlan 内的端口通信;在 isolated vlan 内的端口和在 community vlan 内的端口之间不
能通信。只有不包含任何以太网端口的 vlan 才能被设置为 private vlan;只有设置了关联关 系的 private vlan 才能 access 类型的以太网端口设置为成员端口;普通 vlan 若被设置成
privatevlan 后,会自动将所属以太网端口清空。
gvrp 不传播 private vlan 的信息。
举例:将 vlan100、200、300 设置为 privatevlan,类型分别为 primary、isolated、community。
switch(config)#vlan 100
switch(config-vlan100)#exit
switch(config-vlan100)#private-vlan primary
switch(config)#vlan 200
switch(config-vlan200)#private-vlan isolated
switch(config-vlan200)#exit
switch(config)#vlan 300
switch(config-vlan300)#private-vlan community
switch(config-vlan300)#exit
9.2.2.10 private-vlan association
神州数码交换机配置基本命令

命令:private-vlan association [secondary-vlan-list]
no private-vlan association
功能:设置 private vlan 的绑定操作,该命令的 no 操作为取消 private vlan 绑定。
参数: [secondary-vlan-list] 为与指定 primary vlan 相关关联的 secondary vlan 列表, secondary vlan 包括 isolated vlan 和 community vlan 两种,支持“;”连接多个 secondary vlan。
命令模式:vlan 配置模式
缺省情况:缺省没有 private vlan 绑定。
使用指南:只有primary类型的vlan才能设置private vlan关联关系;被关联到primary vlan
上的 secondary vlans 内的各个端口可以和关联的 primary vlan 内的各个端口进行通信。
在设置 private vlan 关联前,三种类型的 private vlan 都没有以太网端口的成员端口;存
在 private vlan 关联关系的 primary vlan 不能被删除;被解除关联关系的 privatevlans 会自动
将所属成员端口清空。
举例:将 isolated vlan200、community vlan300 关联到 primary vlan100 上。
switch(config-vlan100)#private-vlan association 200;300

©️2020 CSDN 皮肤主题: 书香水墨 设计师:CSDN官方博客 返回首页