HDU 1711 Number Sequence (KMP模板题)

Number Sequence


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1


分析:KMP算法模板题。具体见代码

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn1=1e6+10;
const int maxn2=1e4+10;
int a[maxn1];
int b[maxn2];
int next[maxn2];
int N,M;

void get_next(){
	next[0]=0;
	int k=0;
	for(int p=1;p<M;p++){
		while(k>0 && b[k]!=b[p]){
			k=next[k-1];
		}
		
		if(b[k]==b[p])k++;
		
		next[p]=k;
	}
}

void KMP(){
	get_next();
	int k=0;
	int i=0;
   	while(k<M && i<N){
   	 if(a[i]==b[k]){
   	 	i++;k++;
		}	
	  else if(k==0)    //当匹配长度为0时
	         i++;
	  else 
	       k=next[k-1];
	}
	
	if(k==M)printf("%d\n",i-M+1);
	else printf("-1\n");
}

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&N,&M);
		for(int i=0;i<N;i++)
		scanf("%d",&a[i]);
		
		for(int i=0;i<M;i++)
		scanf("%d",&b[i]);
		
		KMP();
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值