POJ 2481 Cows (树状数组)

Cows
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18542 Accepted: 6238

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i.

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

题意: 对一头奶牛都一个区间,求这个区间被其他区间完全包含的个数(不能重合)。

分析:树状数组求解,首先用结构体存储数据,然后按照 Ei增序排序,若Ei==Ej,则按照Si降序排序。这样处理之后就只需从N向前考虑Si就行了(不断更新C数组),也就是找逆序数。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn= 1e5+10;
int Max;
int C[maxn];
int a[maxn];
struct node{
	int a,b,pos;
}nt[maxn];

bool cmp(const node& n1,const node& n2){
     return n1.b<n2.b || (n1.b==n2.b&&n1.a>=n2.a);
}

int lowbit(int i){
	return i&-i;
}

void update(int i){
	while(i<=Max+1){
		C[i]++;
		i+=lowbit(i); 
	}
}

int sum(int i){
	int ans=0;
	while(i){
		ans+=C[i];
		i-=lowbit(i);
	}
	return ans;
}

int main(){
	int N;
	while(scanf("%d",&N)==1 && N){
		memset(C,0,sizeof(C));
		memset(a,0,sizeof(a));
		Max=0;
		
		for(int i=1;i<=N;i++){
			scanf("%d%d",&nt[i].a,&nt[i].b);
			Max=max(Max,nt[i].a);
			nt[i].pos=i;
		}
		
		sort(nt+1,nt+N+1,cmp);
		
		update(nt[N].a+1); //将最后一个节点也要更新进去 
		for(int i=N-1;i>=1;i--){
			if(nt[i].b==nt[i+1].b && nt[i].a==nt[i+1].a){
				update(nt[i].a+1);
				a[nt[i].pos]=a[nt[i+1].pos];
				continue;
			}
			
			update(nt[i].a+1);
			a[nt[i].pos]=sum(nt[i].a+1)-1;//注意这里不要写成了sum(nt[i].a); 
		}
		
		printf("%d",a[1]);
		for(int i=2;i<=N;i++)
		printf(" %d",a[i]);
		printf("\n");
	}
	return 0;
}


讨论组找到的一组测试数据:

9
5 5
5 6
1 4
4 5
1 4
4 6
2 3
3 5
1 4

输出:4 1 0 2 0 0 3 0 0

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值