hdu 1256. 画八。。一直WA。后来才发现最后的空行错了,还有就是函数的,类型错了,要吸取教训啊。。

Problem Description
谁画8画的好,画的快,今后就发的快,学业发达,事业发达,祝大家发,发,发.


Input
输入的第一行为一个整数N,表示后面有N组数据.
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度.
 

Output
画横线总是一个字符粗,竖线随着总高度每增长6而增加1个字符宽.当总高度从5增加到6时,其竖线宽度从1增长到2.下圈高度不小于上圈高度,但应尽量接近上圈高度,且下圈的内径呈正方形.
每画一个"8"应空一行,但最前和最后都无空行.
 

Sample Input
  
  
2 A 7 B 8
 

Sample Output
  
  
AA AA AA AA AA AA AA AA AA AA AA BBB BB BB BB BB BBB BB BB BB BB BB BB BBB

//HDU1256 画八 
#include<iostream>
using namespace std;

void coutNull(int num)
{
    for(int i=0;i<num;i++)
       cout<<" ";
    }
    
void coutChar(int num,char ch)
{
    for(int i=0;i<num;i++)
       cout<<ch;
    }

int main()
{
    int N;
    cin>>N;
    while(N--)
    {
              int high,vertical=0,width=0;;
              char ch;
              cin>>ch>>high;
              vertical=high/6+1;//普通的竖线宽度 
              width=high-3-(high-3)/2;//特殊三行的字母宽度
              for(int j=0;j<high;j++)
              {
                      if( j==0 || j==(high-3)/2+1 || j==high-1)
                      {
                          coutNull(vertical);
                          coutChar(width,ch);                         
                          }
                      else
                      {
                          coutChar(vertical,ch);
                          coutNull(width);
                          coutChar(vertical,ch);
                          }
                      cout<<endl; 
                      }
              if(N!=0) cout<<endl;
              }
    //system("pause");
    return 0; 
    } 
    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值