poj-1426 Find The Multiple

Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18390 Accepted: 7445 Special Judge

 

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

?

1

2

3

4

2

6

19

0

Sample Output

?

1

2

3

10

100100100100100100

111111111111111111

 

题意:找一个大于等于N的数,使这个数每一位只有0和1,且能被N整除

 

同余模定理:找一个大于等于N的数,使这个数每一位只有0和1,且能被N整除

代码:1

#include<stdio.h>
#define N 600000
int mod[N];
int ans[200];
int main()
{
    int i,k,n;
    while(scanf("%d",&n),n)
    {
        mod[1]=1%n; 
        for(i=2;mod[i-1]!=0;i++)
        {                    
            mod[i]=(mod[i/2]*10+i%2)%n;
        }
        i--;
        k=0;
        while(i)
        {
            ans[k++]=i%2;
            i/=2;
        }
        for(i=k-1;i>=0;i--)
            printf("%d",ans[i]);
        puts("");
    }
    return 0;
}
代码:2
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,flag;
void f( unsigned __int64 x,int n,int k )
{
    if(flag)
        return ;
    if(x%n==0)
    {
        printf("%I64u\n",x);
        flag=1;
        return ;
    }
    if(k==19)
        return ;
    f(x*10,n,k+1);
    f(x*10+1,n,k+1);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        flag=0;
        f(1,n,0);
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值