Find The Multiple(深搜找倍数)

Find The Multiple

 

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
 

题目介绍:(这个题我是真的没翻译懂,很尴尬。。。。。)

题目大意是给出一个数n,找出一个数要求是n的倍数,并且这个数的十进制只由1和0组成,明显这样的数不止一个(如果,满足条件一定会有m×10也满足,故不止一种),题目要求输出任意一个满足该条件的m
对于数据1,可知2×5=10,故答案可以得出是10(当然,100,1000...也满足,但是special judge,只用输出一个满足条件的解),其他数据也同理。此题中,最后需要输出的数据很大,因此需要用 _int64,关于这方面的知识,我也是第一次了解,详见http://blog.csdn.net/zhangxiaoduoduo/article/details/78196982

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int n;int flag;
void dfs(unsigned __int64 t,int k)
{
	if(flag==1)	return ;          //找到答案后就可以停止了 
	if(t%n==0){
		printf("%I64u\n",t);      
		flag=1;
		return ;	
	}
	if(k==19)	return;	         //19位以后就超出了可表示范围,所以要返回 
	dfs(10*t,k+1);
	dfs(10*t+1,k+1);
}

int main()
{
	while(scanf("%d",&n)&&n){
		flag=0;
		dfs(1,0);
	}
	return 0;
} 



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 9
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 9
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值