Prime Path

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24392 Accepted: 13464

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

题目大意:就是 给定两个四位素数 a  b ,要求把 a 变换到 b 变换的过程要保证    每次变换出来的数都是一个   四位素数,而且当前这步的变换所得的素数       前一步得到的素数   只能有一个数不同,而且每步得到的素数都不能重复。   求从 a b 最少需要的变换次数。无法变换则输出 Impossible
代码:
#include<stack>
#include<queue>
#include<math.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int prime[20000];
struct node
{
    int x,y,step;
} p,q;
void isprime()//素数打表prime[i]=0为素数
{
    int i,j;
    memset(prime,0,sizeof(prime));
    prime[1]=1;
    for(i=2; i<20000; i++)
    {
        if(prime[i]==0)
        {
            for(j=2; j*i<20000; j++)
                prime[j*i]=1;
        }
    }
}
int bfs(int s,int e)
{
    int vis[20000],num;
    memset(vis,0,sizeof(vis));
    queue<node>Q;
    p.x=s;
    p.step=0;
    vis[s]=1;
    Q.push(p);
    while(!Q.empty())//当队列不为空时
    {
        p=Q.front();//取队首
        Q.pop();//清队首
        if(p.x==e)
            return p.step;
        int t[5];
        t[1]=p.x/1000;//记录千位数
        t[2]=p.x/100%10;//记录百位数
        t[3]=p.x/10%10;//记录十位
        t[4]=p.x%10;//记录个位
        for(int i=1;i<=4;i++)
        {
            int temp=t[i];//这里特别注意,每次只能变换一位数,这里用来保存该变换位的数,变换下一位数时,该位数要恢复
            for(int j=0;j<10;j++)
            {
                if(t[i]!=j)
                {
                    t[i]=j;
                    num=t[1]*1000+t[2]*100+t[3]*10+t[4];
                }
                if(num>=1000&&num<=9999&&!vis[num]&&!prime[num])
                {
                    q.x=num;
                    q.step=p.step+1;///若满足,步数加1,
                    Q.push(q);
                    vis[num]=1;
                }
            }
            t[i]=temp;
        }
    }
    return -1;
}
int main()
{
    int test,a,b,ans=0;
    isprime();
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d%d",&a,&b);
        ans=bfs(a,b);
        if(ans!=-1)
            printf("%d\n",ans);
        else
            printf("Impossible\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值