HDU-1208

Pascal's Travels

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2658    Accepted Submission(s): 1259

 

 

Problem Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 

 

Figure 1

 

 

Figure 2

 

 

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

 

 

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 

 

 

Sample Input

 

4 2331 1213 1231 3110 4 3332 1213 1232 2120 5 11101 01111 11111 11101 11101 -1

 

 

Sample Output

 

3 0 7

Hint

Hint Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as "__int64" values using the Visual C/C++ or "long long" values using GNU C/C++ or "int64" values using Free Pascal compilers.

 

 

Source

Mid-Central USA 2005

题意:就是让你找出有多少条路

刚开始用的广搜,内存炸了

错误代码:

#include<stdio.h>
#include <string.h>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    int x,y,step;
}in,out;
int map[40][40];
int n,sum,end_x,end_y;
int yidong[2][2] = {{1,0},{0,1}};
int check(int x,int y)
{
    if(x >= 0 && x < n && y >= 0 && y < n && (map[x][y] || (!map[x][y] && x == n-1 && y == n-1)))
        return 1;
    return 0;
}
void bfs()
{
    int i;
    queue<node> Q;
    in.x  = 0;
    in.y = 0;
    Q.push(in);
    while(!Q.empty())
    {
        out = Q.front();
        Q.pop();
        if(out.x == n-1&&out.y == n-1)
        {
            sum++;
        }
        else
        {
            for(i=0; i<2; i++)
            {
                in.x = out.x + yidong[i][0] * map[out.x][out.y];
                in.y = out.y + yidong[i][1] * map[out.x][out.y];
                if(check(in.x,in.y))
                {
                    Q.push(in);
                }
            }
        }
    }
}
int main()
{
    int i,j,l;
    char s1[35];
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)
            break;
        sum = 0;
        l = 0;
        for(i=0; i<n; i++)
        {
            scanf("%s",s1);
            for(j=0; j<n; j++)
            {
                map[i][j] = s1[j] - '0';
            }
        }
        bfs();
       printf("%d\n",sum);
    }
    return 0;
}

正确代码:

#include<stack>
#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define max(a,b)a>b?a:b
#define min(a,b)a>b?b:a
int map[100][100],ans;
long long dp[100][100];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)
            break;
        int i,j;
        ans=0;
        char s1[100];
        for(i=0; i<n; i++)
        {
            scanf("%s",s1);
            for(j=0; j<n; j++)
            {
                map[i][j]=s1[j]-'0';
            }
        }
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
            {
                if(map[i][j]==0)
                    continue;
                if(i+map[i][j]<n)
                    dp[i+map[i][j]][j]+=dp[i][j];
                if(j+map[i][j]<n)
                    dp[i][j+map[i][j]]+=dp[i][j];
            }
        }
        printf("%lld\n",dp[n-1][n-1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值