HDU-2612-Find a way

该博客讨论了一个问题,即两个人从不同地点出发,如何选择一个肯德基(KFC)作为会面点,使得两人的总路程最短。博主提出了使用两个广度优先搜索(BFS)策略分别计算每个人到所有KFC的距离,然后比较并乘以费用以确定最佳方案。博客内容包括问题描述、解决思路和相关代码。
摘要由CSDN通过智能技术生成

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20967    Accepted Submission(s): 6798


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
 
 
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
 
 
66 88 66
 

Author
yifenfei
 

Source

题目大意:两个人在两个不同的地方,现在两个人要选择一个肯德基店进行会面,问如何1在地图上找到一个KFC使两人总的路径最短

思路:用两个bfs去分别搜索两个人到每个KFC的距离,然后比较一下,乘以价格就可以了

代码:

#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
char a[1000][1000];    
int ans[1001],ans1[1001],ans2[1001];
int mark[1000][1000];
int dis[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
int st_x1,st_x2,st_y1,st_y2,Min,cnt;
int m,n;
struct node
{
    int x,y,step;
}s1,s2,sss[1001];
int judge(int x,int y)
{
    int i;
    for(i=1;i<cnt;i++)
    {
        if(sss[i].x==x&&sss[i].y==y)
        {
            return i;
        }
    }
    return 0;
}
void BFS_Y(int x,int y)
{
    int i;
    queue<node>Q;
   s1.x=x;
   s1.y=y;
   s1.step=0;
   Q.push(s1);
   memset(ans,0,sizeof(ans));
   memset(mark,0,sizeof(mark));
   mark[s1.x][s1.y]=1;
   while(!Q.empty())
   {
       s1=Q.front();
       Q.pop();
       int t=judge(s1.x,s1.y);
       if(t)
       {
           ans[t]=s1.step;
           mark[s1.x][s1.y]=1;
       }
       for(i=0;i<4;i++)
       {
           s2=s1;
           s2.x+=dis[i][0];
           s2.y+=dis[i][1];
           s2.step++;
           if((a[s2.x][s2.y]=='.'||a[s2.x][s2.y]=='@')&&mark[s2.x][s2.y]==0)
           {
               Q.push(s2);
               mark[s2.x][s2.y]=1;
           }
       }
   }
   for(i=1;i<cnt;i++)
   {
       if(ans[i])
        ans1[i]=ans[i];
       else
        ans1[i]=-1;
   }
}
void BFS_M(int x,int y)
{
    int i;
    queue<node>Q;
    s1.x=x;
    s1.y=y;
    s1.step=0;
    Q.push(s1);
    memset(ans,0,sizeof(ans));
    memset(mark,0,sizeof(mark));
    mark[s1.x][s1.y]=1;
    while(!Q.empty())
    {
        s1=Q.front();
        Q.pop();
        int t=judge(s1.x,s1.y);
        if(t)
        {
            ans[t]=s1.step;
            mark[s1.x][s1.y]=1;
        }
        for(i=0;i<4;i++)
        {
            s2=s1;
            s2.x+=dis[i][0];
            s2.y+=dis[i][1];
            s2.step++;
            if((a[s2.x][s2.y]=='.'||a[s2.x][s2.y]=='@')&&mark[s2.x][s2.y]==0)
            {
                Q.push(s2);
                mark[s2.x][s2.y]=1;
            }
        }
    }
    for(i=1;i<cnt;i++)
    {
        if(ans[i])
            ans2[i]=ans[i];
        else
            ans2[i]=-1;
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,j;
        getchar();
        Min=999999;
        cnt=1;
        memset(a,'#',sizeof(a));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='Y')
                {
                    st_x1=i;
                    st_y1=j;
                }
                else if(a[i][j]=='M')
                {
                    st_x2=i;
                    st_y2=j;
                }
                else if(a[i][j]=='@')
                {
                    sss[cnt].x=i;
                    sss[cnt++].y=j;
                }
            }
            getchar();
        }
        BFS_Y(st_x1,st_y1);
        BFS_M(st_x2,st_y2);
        for(i=1;i<cnt;i++)
        {
            if(ans1[i]!=-1&&ans2[i]!=-1)
            {
                int t=ans1[i]+ans2[i];
                if(t<Min)
                {
                    Min=t;
                }
            }
        }
        printf("%d\n",Min*11);
    }
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值