hdu-1224-Free DIY Tour

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8375    Accepted Submission(s): 2714

Poblem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.
The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 
Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.
Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

Output a blank line between two cases.

Sample Input

2 3 0 70 90 4 1 2 1 3 2 4 3 4 3 0 90 70 4 1 2 1 3 2 4 3 4

Sample Output

CASE 1#

points : 90

circuit : 1->3->1

CASE 2#

points : 90

circuit : 1->2->1

Author

JGShining(极光炫影)

Source

杭州电子科技大学第三届程序设计大赛

题目大意:伟伟出去旅行,现在给你各个城市的趣味值,和能够直飞的航班,注航班只能从编号小的城市飞往大的城市,例如只能从1飞到2,3,4等,2只能飞到3,4,5等然后现在让你求他该如何计划路线使得旅行的趣味值最大,且能飞回来

思路:最长路,但是要记录路径

代码:

#include<map>
#include<stack>
#include<cmath>
#include<queue>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 110
#define inf 9999999
#define ll long long
int n;
int qu[maxn];//城市趣味值
int ans[maxn];
int lujin[maxn];//记录路径
int e[maxn][maxn];
int main()
{
    int test,q=1;
    scanf("%d",&test);
    while(test--)
    {
        if(q!=1)
            printf("\n");
        int i,j,k,m,maxx=-1,sum=0;
        scanf("%d",&n);
        qu[0]=0;//第一个城市趣味值一定为0
        for(i=1; i<=n; i++)
            scanf("%d",&qu[i]);
        qu[n+1]=0;
        memset(e,0,sizeof(e));
        scanf("%d",&m);
        int u,v;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            e[u][v]=1;//标记为1;
        }
        ans[1]=-1;
        for(i=1; i<=n+1; i++)
        {
            maxx=-1,k=0;
            for(j=1; j<i; j++)
            {
                if(e[j][i]&&qu[j]>maxx)
                {
                    k=j;
                    maxx=qu[j];
                }
            }
            if(maxx!=-1)
            {
                ans[i]=k;
                qu[i]+=maxx;
            }
        }
        printf("CASE %d#\n",q++);
        printf("points : %d\n",qu[n+1]);
        printf("circuit : ");
        k=n+1;
        int z=0;
        while(ans[k]!=-1)
        {
            lujin[z++]=ans[k];
            k=ans[k];
        }
        for(i=z-1; i>=0; i--)
            printf("%d->",lujin[i]);
        printf("1\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值