POJ 1703 Find them, Catch them

 H - Find them, Catch them
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 


Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 


1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 


2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.

In the same gang.


看了三天,又百度了下,,,,,

思路:

两种种族并查集在链表里是以ABABABABAB连接的,所以只需求出它与根的距离。

合并也要注意,


代码1:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MA 100100
int fer[MA];
int lei[MA];
int find(int xx)
{
	int p=xx;
	lei[p]=0;
	while (fer[xx]!=xx)
	{
		lei[p]++;//求距离
		xx=fer[xx];
	}
	if (lei[p]%2==1)
	fer[p]=xx;
	else
	fer[fer[p]]=xx;
	return xx;
}
void uion(int aa,int bb)
{
	int fa=find(aa);
	int fb=find(bb);
	if (fa==fb) return ;//避免死循环。
	if ((lei[aa]%2)==(lei[bb]%2))//开始合并。
	fer[fa]=fb;
	else if ((lei[aa]%2)==0)
	fer[fa]=bb;
	else
	fer[fb]=aa;
}
int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		int n,m,a,b;
		char ch[5];
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		fer[i]=i;
		for (int i=0;i<m;i++)
		{
			scanf("%s%d%d",&ch,&a,&b);
			if (ch[0]=='A')
			{
				if (find(a)==find(b))
				{
					if ((lei[a]%2)==(lei[b]%2))
					printf("In the same gang.\n");
					else
					printf("In different gangs.\n");
				}
				else
				{
					if(n==2) printf("In different gangs.\n");
					else printf("Not sure yet.\n");
				}
			}
			else
			{
				uion(a,b);
			}
		}
	}
	return 0;
 } 

代码2:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int fer[200100];
int shu[200100];
int find(int xx)
{
	if (fer[xx]==xx)
	{
		shu[xx]=0;
		return xx;
	}
	else
	{
		int ff=fer[xx];
		int rx=find(ff);
		shu[xx]=shu[ff]+1;
		if (shu[xx]%2==1)
		fer[xx]=rx;
		return rx;
	}
}
int main()
{
	int t;scanf("%d",&t);
	while (t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		for (int i=1;i<=n;i++)
			fer[i]=i;
		int a,b,lp=n+1;char ch[2];
		while (m--)
		{
			scanf("%s%d%d",ch,&a,&b);
			if (ch[0]=='A')
			{
				if (find(a)==find(b))
				{
					if ((shu[a]+shu[b])%2==0)
						printf("In the same gang.\n");
					else
						printf("In different gangs.\n");
				}
				else
					printf("Not sure yet.\n");
			}
			else
			{
				int aa=find(a);
				int bb=find(b);
				if (aa==bb)
				continue;
				if ((shu[a]+shu[b])%2==0)
					fer[aa]=bb;
				else
			 	{
			 		fer[aa]=lp;
			 		fer[lp++]=bb;
				}
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值