A+B Problem II
时间限制:3000 ms | 内存限制:65535 KB
难度:3
描述
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
A,B must be positive.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
来源
经典题目
上传者
张云聪
代码:
#include<cstdio>
#include<cstring>
int main()
{
int t;
scanf("%d",&t);
for (int ca=1;ca<=t;ca++)
{
char a[1020],b[1020];
int aa[1020]={0},bb[1020]={0};
scanf("%s%s",a,b);
printf("Case %d:\n%s + %s = ",ca,a,b);
int al=strlen(a);
int bl=strlen(b);
for (int i=0;i<al;i++)
aa[i]=a[al-1-i]-'0';
for (int i=0;i<bl;i++)
bb[i]=b[bl-1-i]-'0';
if (al>=bl)
for (int ii=0;ii<al;ii++)
{
aa[ii]+=bb[ii];
if (aa[ii]>9&&ii!=al-1)
{
aa[ii+1]++;
aa[ii]%=10;
}
}
else
for (int ii=0;ii<bl;ii++)
{
bb[ii]+=aa[ii];
if (bb[ii]>9&&ii!=bl-1)
{
bb[ii+1]++;
bb[ii]%=10;
}
}
if (al>=bl)
for (int ii=al-1;ii>=0;ii--)
printf("%d",aa[ii]);
else
for (int ii=bl-1;ii>=0;ii--)
printf("%d",bb[ii]);
printf("\n");
}
return 0;
}