hdoj 1028 Ignatius and the Princess III <递归+状态记录优化----母函数????>

20 篇文章 0 订阅
11 篇文章 0 订阅

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18588    Accepted Submission(s): 13021


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 

Author
Ignatius.L
 

递归-----飘过---


只递归会   TLE     代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
LL shu[130];
LL f(int da,int pp)
{
    if (pp==0)
        return 1;
    if (da==0)
        return 0;
    LL lp=0;
    for (int i=da;i>0;i--)
    {
        int ge=pp/i;
        for (int j=1;j<=ge;j++)
        {
            lp+=f(min(i-1,pp-j*i),pp-j*i);
        }
    }
    return lp;
}
int main()
{
    int n;
    memset(shu,0,sizeof(shu));
    while (~scanf("%d",&n))
    {
        if (shu[n])
            printf("%lld\n",shu[n]);
        else
        {
            shu[n]=f(n,n);
            printf("%lld\n",shu[n]);
        }
    }
    return 0;
}


递归+状态记录优化  代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
LL shu[130],F[130][130];
LL f(int da,int pp)
{
    if (pp==0)
        return 1;
    if (da==0)
        return 0;
    LL lp=0;
    for (int i=da;i>0;i--)
    {
        int ge=pp/i;
        for (int j=1;j<=ge;j++)
        {
            if (!F[min(i-1,pp-j*i)][pp-j*i])
            F[min(i-1,pp-j*i)][pp-j*i]=f(min(i-1,pp-j*i),pp-j*i);
            lp+=F[min(i-1,pp-j*i)][pp-j*i];
            //lp+=f(min(i-1,pp-j*i),pp-j*i);
        }
    }
    return lp;
}
int main()
{
    int n;
    memset(shu,0,sizeof(shu));
    memset(F,0,sizeof(F));
    while (~scanf("%d",&n))
    {
        if (shu[n])
            printf("%lld\n",shu[n]);
        else
        {
            shu[n]=f(n,n);
            printf("%lld\n",shu[n]);
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值