LightOJ 1258 Making Huge Palindromes 【Manacher算法】


题目链接:传送


Time Limit: 1000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu

Submit Status uDebug

Description

A string is said to be a palindrome if it remains same when read backwards. So, 'abba', 'madam' both are palindromes, but 'adam' is not.

Now you are given a non-empty string S, containing only lowercase English letters. The given string may or may not be palindrome. Your task is to make it a palindrome. But you are only allowed to add characters at the right side of the string. And of course you can add any character you want, but the resulting string has to be a palindrome, and the length of the palindrome should be as small as possible.

For example, the string is 'bababa'. You can make many palindromes including

bababababab

babababab

bababab

Since we want a palindrome with minimum length, the solution is 'bababab' cause its length is minimum.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with a line containing a string S. You can assume that 1 ≤ length(S) ≤ 106.

Output

For each case, print the case number and the length of the shortest palindrome you can make with S.

Sample Input

4

bababababa

pqrs

madamimadam

anncbaaababaaa

Sample Output

Case 1: 11

Case 2: 7

Case 3: 11

Case 4: 19

Hint

Dataset is huge, use faster I/O methods.


Problem Setter: Jane Alam Jan
Developed and Maintained by 
JANE ALAM JAN
Copyright © 2012 
LightOJ, Jane Alam Jan

Source

Problem Setter: Jane Alam Jan


在字符串的右边加入元素使之成为回文串---问所能形成回文串的最短长度-.-


设字符串S----反串为T

我们如果直接将T加入到S的后面一定是回文串-.-

让长度尽可能的少-.-就是让T和S重叠的最多-.-

重叠部分一定是回文串且一定在S的最后面结束----.-

问题就转换为最大的以S末尾结束的回文串的长度-.-


代码“:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char ch[1000100];
char T[2000200];
int P[2000200];
int main()
{
	int t;scanf("%d",&t);
	for (int ca=1;ca<=t;ca++)
	{
		scanf("%s",ch);
		int ll=strlen(ch);
		memset(T,0,sizeof(T));
		memset(P,0,sizeof(P));
		for (int i=0;i<=ll;i++)
		{
			T[2*i+1]='#';
			T[2*i+2]=ch[i];
		}
		T[0]=-1;
		ll=2*ll;
		int mid=0,ss=0,ans=0;
		for (int i=1;i<=ll;i++)
		{
			if (ss>i)
			P[i]=min(ss-i,P[2*mid-i]);
			else
			P[i]=1;
			while (T[i-P[i]]==T[i+P[i]])
			P[i]=P[i]+1;
			if (i+P[i]>ss)
			{
				ss=i+P[i];
				mid=i;
			}
			if (ss>ll)//以T[i]为中心的字符串以到T的末尾--
			{
				ans=P[i]-1;
				break;
			}
		}
		printf("Case %d: %d\n",ca,ll-ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值