湖南省第十二届大学生计算机程序设计竞赛 2016

1803: 2016

Time Limit: 5 Sec   Memory Limit: 128 MB
Submit: 537   Solved: 343
[ Submit][ Status][ Web Board]

Description

 给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:

1. 1≤a≤n,1≤b≤m;

2. a×b 是 2016 的倍数。

Input

输入包含不超过 30 组数据。

每组数据包含两个整数 n,m (1≤n,m≤10 9).

Output

对于每组数据,输出一个整数表示满足条件的数量。

Sample Input

32 63
2016 2016
1000000000 1000000000

Sample Output

1
30576
7523146895502644

HINT

Source



我去湖南也会爆零-----------


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
int A[2020]; 
int shu[100];
int main()
{
	LL n,m;
	for (int i=1;i<=2016;i++)
	{
		if (2016%i==0)
		{
			for (int j=i;j<=2016;j+=i)
			A[j]=2016/i;
		}
	}
	while(~scanf("%lld%lld",&n,&m))
	{
		LL a=n/2016;
		LL b=n%2016;
		a++;
		if (b==0) a--;
		LL s=0;
		for (int i=1;i<=2016&&i<=n;i++)
		{
			s+=m/A[i]*a;
			if (i==b)
			a--;
		}
		printf("%lld\n",s);
	}
	return 0;
}





  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值