poj 3259 Wormholes 【spfa判负环---求最短路】

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45543 Accepted: 16808

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.



题意:

有n个点,m个双向路径,w个虫洞。

路径花费正数时间,虫洞花费负数时间。

求能否经过若干条路径回来过去---


思路:

spfa判负环...


spfa思想----


不断地向队列中添加队列中没有的距离变小的点(再次被优化的)。

然后拿队列中的点去优化其他路径-----

如果有某一点多次进去队列说明路径形成了环,次数超过N次,一定是负环。



代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int ma[1000][1000],dis[1000],ci[1000];
int que[400000],kp,top,n,m,w;
bool falg[1000];
int main()
{
    int t;scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d%d",&n,&m,&w);
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=n;j++)
                ma[i][j]=99999999;
            dis[i]=99999999;
            falg[i]=false;
            ci[i]=0;
        }
        int a,b,c;
        for (int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            ma[a][b]=ma[b][a]=min(ma[a][b],c);
        }
        for (int i=0;i<w;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            ma[a][b]=min(ma[a][b],-c);
        }
        bool fafe=false;
        top=0;kp=0;
        dis[1]=0;
        que[kp++]=1;
        while (top<kp)
        {
            int p=que[top++];
            falg[p]=false;
            if (ci[p]>n)
            {
                fafe=true;
                break;
            }
            for (int i=1;i<=n;i++)
            {
                if (dis[p]+ma[p][i]<dis[i])
                {
                    dis[i]=dis[p]+ma[p][i];
                    if (!falg[i])
                    {
                        falg[i]=true;
                        ci[i]++;
                        que[kp++]=i;
                    }
                }
            }
        }
        if (fafe)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值