Hdoj Recursive sequence 2016ACM/ICPC亚洲区沈阳站 【矩阵加速状态转移】

17 篇文章 0 订阅
8 篇文章 0 订阅

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 46


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.


A(n) = 2*A(n-2) + A(n-1) +n*n.


然后用矩阵加速-.-



代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
int llp;
LL mod;
struct node{
    LL shu[7][7];
    void clear()
    {
        for (int i=0;i<llp;i++)
            for (int j=0;j<llp;j++)
                shu[i][j]=0;
    }
    node operator * (const node &B) const
    {
        node C;
        for (int i=0;i<llp;i++)
            for (int j=0;j<llp;j++)
            {
                C.shu[i][j]=0;
                for (int k=0;k<llp;k++)
                    C.shu[i][j]=(C.shu[i][j]+shu[i][k]*B.shu[k][j])%mod;
            }

        return C;
    }
}A,B,e,f;
LL lie[7];
void ss()
{
    e.clear();
    f.clear();
    for (int i=0;i<7;i++)
        e.shu[i][i]=1;
    f.shu[0][0]=f.shu[0][2]=f.shu[1][0]=f.shu[2][2]=f.shu[2][6]=f.shu[3][3]=1;
    f.shu[3][6]=f.shu[4][4]=f.shu[4][6]=f.shu[5][5]=f.shu[5][6]=f.shu[6][6]=1;
    f.shu[0][1]=f.shu[4][5]=2;
    f.shu[3][4]=f.shu[3][5]=3;
    f.shu[2][3]=f.shu[2][5]=4;
    f.shu[2][4]=6;
    lie[2]=81;lie[3]=27;lie[4]=9;lie[5]=3;lie[6]=1;
}
LL pp(int n)
{
    if (n==1)
        return lie[1];
    else if (n==2)
        return lie[0];
    n-=2;
    A=e;
    B=f;
    while (n)
    {
        if (n&1)
            A=A*B;
        B=B*B;
        n>>=1;
    }
    LL ans=0;
    for (int i=0;i<llp;i++)
        ans=(ans+A.shu[0][i]*lie[i])%mod;
    return ans;
}
void slove()
{
    int n;LL a,b;ss();
    scanf("%d%lld%lld",&n,&a,&b);
    lie[0]=b;
    lie[1]=a;
    LL ans=pp(n);
    printf("%lld\n",ans);
}
int main()
{
    llp=7;
    mod=2147493647;
    int t;scanf("%d",&t);
    while (t--)
        slove();
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值