hdu 5950 Recursive sequence

Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.


思路:根据递推式求f(n),矩阵快速幂



#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>

using namespace std;

const double EXP = 1e-9;
typedef long long ll;
const ll maxn = 7;
const ll mod = 2147493647;

struct mat
{
    ll m[maxn][maxn];
}unit;   //unit为单位矩阵

void init_unit()    //初始化单位矩阵
{
    for(ll i=0;i<maxn;i++)
        unit.m[i][i] = 1;
    return ;
}

mat matmul(mat a,mat b)
{
    mat ans;
    ll x,i,j,k;
    for(i=0;i<maxn;i++)
    {
        for(j=0;j<maxn;j++)
        {
            x=0;
            for(k=0;k<maxn;k++)
            {
                x+=(a.m[i][k]*b.m[k][j])%mod;
            }
            ans.m[i][j] = x%mod;
        }
    }
    return ans;
}

mat pow_mat(mat a,ll n)
{
    mat ans = unit;
    while(n)
    {
        if(n&1)
            ans=matmul(ans,a);
        a = matmul(a,a);
        n>>=1;
    }
    return ans;
}


int main()
{
    //printf("%lld\n",mod);
    ll t,n,A,B;
    init_unit();
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld%lld",&n,&A,&B);
        if(n==1)
            cout<<A<<endl;
        else if(n==2)
            cout<<B<<endl;
        else
        {
            mat a,b;  //a为表达式矩阵,b为快速幂矩阵
            //以下为俩矩阵的初始化
            b.m[0][0] = 1,b.m[0][1] = 1,b.m[0][2] = 0,b.m[0][3] = 0,b.m[0][4] = 0,b.m[0][5] = 0,b.m[0][6] = 0;
            b.m[1][0] = 2,b.m[1][1] = 0,b.m[1][2] = 0,b.m[1][3] = 0,b.m[1][4] = 0,b.m[1][5] = 0,b.m[1][6] = 0;
            b.m[2][0] = 1,b.m[2][1] = 0,b.m[2][2] = 1,b.m[2][3] = 0,b.m[2][4] = 0,b.m[2][5] = 0,b.m[2][6] = 0;
            b.m[3][0] = 4,b.m[3][1] = 0,b.m[3][2] = 4,b.m[3][3] = 1,b.m[3][4] = 0,b.m[3][5] = 0,b.m[3][6] = 0;
            b.m[4][0] = 6,b.m[4][1] = 0,b.m[4][2] = 6,b.m[4][3] = 3,b.m[4][4] = 1,b.m[4][5] = 0,b.m[4][6] = 0;
            b.m[5][0] = 4,b.m[5][1] = 0,b.m[5][2] = 4,b.m[5][3] = 3,b.m[5][4] = 2,b.m[5][5] = 1,b.m[5][6] = 0;
            b.m[6][0] = 1,b.m[6][1] = 0,b.m[6][2] = 1,b.m[6][3] = 1,b.m[6][4] = 1,b.m[6][5] = 1,b.m[6][6] = 1;

            a.m[0][0] = B,a.m[0][1] = A,a.m[0][2] = 16,a.m[0][3] = 8,a.m[0][4] = 4,a.m[0][5] = 2,a.m[0][6] = 1;
            b = pow_mat(b,n-2);
            a = matmul(a,b);
            printf("%lld\n",a.m[0][0]%mod);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值