HDU 4287 - Intelligent IME

Problem Description

  We all use cell phone today. And we must be familiarwith the intelligent English input method on the cell phone. To be specific,the number buttons may correspond to some English letters respectively, asshown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, thenthe input method will choose from an embedded dictionary, all words matchingthe input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given adictionary, how many words in it match some input number sequences?

 

 

Input

  First is an integer T, indicating the number of testcases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M<= 5000), indicating the number of input number sequences and the number ofwords in the dictionary, respectively. Then comes N lines, each line contains anumber sequence, consisting of no more than 6 digits. Then comes M lines, eachline contains a letter string, consisting of no more than 6 lower letters. Itis guaranteed that there are neither duplicated number sequences nor duplicatedwords.

 

 

Output

  For each input block, output N integers, indicatinghow many words in the dictionary match the corresponding number sequence, eachinteger per line.

 

 

Sample Input

1

3 5

46

64448

74

go

in

night

might

gn

 

 

Sample Output

3

2

0

 

思路:

因为最大只有6位,将输入的字符串转换为数字,再将对应数字个数+1


代码:
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;

int a[1000005];

int main()
{
	int n, m;
	int b[5005];
	int t;
	scanf("%d", &t);
	while (t--)
	{
		memset(a, 0, sizeof(a));
		// map<int,int> p;
		scanf("%d%d", &n, &m);

		int i;
		for (i = 0; i<n; i++)
		{
			scanf("%d", &b[i]);
		}

		for (i = 0; i<m; i++)
		{
			char st[10];
			scanf("%s", st);
			int len = strlen(st);

			int j, temp = 0;
			for (j = 0; j<len; j++)
			{
				char c = st[j];
				if (c >= 'x')
					c -= 2;
				else
					if (c >= 's')
						c--;

				temp = temp * 10 + 2 + (c - 'a') / 3;
			}
			//printf("%d\n",temp);

			a[temp]++;
		}

		for (i = 0; i<n; i++)
			printf("%d\n", a[b[i]]);
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值