HDU 1043 - Eight

16 篇文章 0 订阅
A - Eight
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
 r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 
 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8 
 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 
 

Sample Input

     
     
2 3 4 1 5 x 7 6 8
 

Sample Output

     
     
ullddrurdllurdruldr

用康托展开做Hash,用BFS从最终状态倒推,得到每种状态的最短路径,路径用后驱的康托数值和对应的操作来记录。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

#define N 363000

struct node{
    int a[10];
    int pos;
    int cant;

    node(int *b,int p,int c){
        memcpy(a,b,sizeof(a));
        pos=p;
        cant=c;
    }
};

int vx[]={0,0,1,-1};
int vy[]={1,-1,0,0};
char op[]="lrud";
int pre[N];
bool vis[N];
char cz[N];
int fac[]={1,1,2,6,24,120,720,5040,40320,362880};

int Cantor(int *s,int n){
    int num=0;
    for (int i=0;i<n;i++){
        int cnt=0;
        for (int j=i+1;j<n;j++)
            cnt+=(s[j]<s[i]);
        num+=fac[n-i-1]*cnt;
    }
    return num;
}

void bfs(){
    memset(pre,-1,sizeof(pre));
    memset(vis,false,sizeof(vis));
    int a[]={1,2,3,4,5,6,7,8,0};
    int cant=Cantor(a,9);
    int pos=8;
    queue<node> q;

    vis[cant]=true;
    q.push(node(a,pos,cant));
    while(!q.empty()){
        node temp=q.front();
        q.pop();

        int x=temp.pos/3;
        int y=temp.pos%3;
        for (int i=0;i<4;i++){
            int tx=x+vx[i];
            int ty=y+vy[i];
            if (tx<0 || tx>=3 || ty<0 || ty>=3)
                continue;

            memcpy(a,temp.a,sizeof(a));
            swap(a[temp.pos],a[tx*3+ty]);
            cant=(Cantor(a,9));
            if (!vis[cant]){
                vis[cant]=true;
                pre[cant]=temp.cant;
                cz[cant]=op[i];
                q.push(node(a,tx*3+ty,cant));
            }
        }
    }
}

void pr(int cant){
    if (pre[cant]==-1)
        return;

    printf("%c",cz[cant]);
    pr(pre[cant]);
}

int main(){
    bfs();
    char st[50];
    while (gets(st)!=NULL){
        int s[10],k=0;
        memset(s,-1,sizeof(s));
        for (int len=strlen(st),i=0;i<len;i++){
            if (st[i]=='x'){
                s[k++]=0;
              //  cout<<s[k-1];
            }
            else{
                if (st[i]!=' '){
                    s[k++]=st[i]-'0';
                    //cout<<s[k-1];
                }
            }
        }
       // cout<<endl;

        int cant=Cantor(s,9);
        if (!vis[cant])
            printf("unsolvable");
        else
            pr(cant);
        printf("\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值