Tree--二叉树的建立

  Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255
写了好久都wrong了,原来是题意理解错了快哭了...英语啊...
思路:给出二叉树的中序和后序序列,重建二叉树,然后求出从根结点到叶子结点值的和,输出和最小的那条路径的叶子的值,若和相同,则输出叶子结点最小的那个.
#include<stdio.h>
#include<malloc.h>
#include<string.h>
#include<math.h>
typedef struct node
{
    int data;
    int sum;
    struct node *lchild;
    struct node *rchild;
};
int L[10005],M[10005],cnt;
void creatTrie(int *l,int *m,int len,node* &q)
{
    if(len==0)
    {
        q=NULL;
        return;
    }
    int i,flag;
    q=(node *)malloc(sizeof(node));
    q->data=l[len-1];
    q->lchild=NULL;
    q->rchild=NULL;
    for(i=0; i<len; i++)
    {
        if(m[i]==q->data)
        {
            flag=i;
            break;
        }
    }
  //  printf("%d ",q->v);
    creatTrie(l,m,flag,q->lchild);
    creatTrie(l+flag,m+flag+1,len-flag-1,q->rchild);
}
int k,sum1;
void visit(node* &p,int x)
{
    if(p==NULL)
        return ;
        p->sum=x+p->data;

    if(p->lchild==NULL&&p->rchild==NULL)
    {
        if(p->sum<=sum1)
        {
            if(p->sum<sum1)
            {
               k=p->data;
                sum1=p->sum;
            }
            else if(p->sum==sum1&&k>p->data)
            {
                k=p->data;
                sum1=p->sum;
            }

        }

       //printf("%d\n",p->sum);
        free(p);
        return;
    }
     visit(p->lchild,p->sum);
     visit(p->rchild,p->sum);
}
int main()
{

    int len,i,l=0;
    char c,s;
    node *q;
    while(scanf("%d%c",&M[l++],&c)!=EOF)
    {
        k=999999;sum1=99999;
        if(c=='\n')
        {
            for(i=0; i<l; i++)
            scanf("%d%c",&L[i],&s);
            creatTrie(L,M,l,q);
            visit(q,0);
            printf("%d\n",k);
            l=0;
        }
    }
    return 0;
}


/*
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255
7 8 11 3 5 9 12 18
8 3 11 7 9 18 12 5
*/
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值