递推-nyoj-The number of maximum subset

The number of maximum subset

描述
You are given a set with n distinct numbers of 1 to n, and your task is to calculate the number of maximum subsets with the following properties:
no two elements in the subset should be adjacent
it shouldn't be possible to add numbers to the subset without violating the first condition
For example, if n = 5, the number of maximum subsets which fulfill the above conditions is 4. The subsets are {1,3,5},{2,4},{2,5},{1,4}. 
输入
The input will consist of a sequence of numbers n,1 ≤ n ≤ 76. Each number will be on a separate line. The input will be terminated by EOF.
输出
Output the number of maximum subsets as described above on a single line. The number of all subsets will be less than 2^31.
样例输入
1
2
3
4
5
30
样例输出
1
2
2
3
4
4410

题意:给你n个不同的数(从1~n),求满足下列条件的子集有多少个。

1)没有两个数在集合中是相邻的

2)在没有违反第一个条件的情况下,不能把数字加到集合里

貌似不太好理解。。。。

当n=5时,符合条件的集合是{1,3,5},{2,4},{2,5},{1,4}.为什么{1,3}不符合呢?因为当集合为{1,3}时,加进去5是不违反第一个条件的,所以就不能把1,3放到集合中。

当元素有n个时,1、把n加进集合中

  2、把n-1加进集合中

1、把n加进集合中,则n-1不能加,n-2能加,所以把n加进集合中的集合个数等于把n-2加进集合中时集合素个数,用s[i]记录把n=i时的最大集合个数,则有s[n]=s[n-2];

2、把n-1加进集合中,则n-2不能加,n-3能加,同理可得s[n-1]=s[n-3]

综上可得一个递推公式:当元素有n个时,s[n]=s[n-2]+s[n-3];

 
#include<stdio.h>
#include<stack>
#include<math.h>
#include<queue>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    int s[100];
    s[1]=1;s[2]=2;s[3]=2;
    for(int i=4;i<=76;i++)
    {
        s[i]=s[i-2]+s[i-3];
    }
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",s[n]);
    }
    return 0;
}
        


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值