poj1006-生理周期-中国剩余定理

生理周期

Description

人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。

Input

输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。 

当p = e = i = d = -1时,输入数据结束。

Output

从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。 

采用以下格式: 
Case 1: the next triple peak occurs in 1234 days. 

注意:即使结果是1天,也使用复数形式“days”。

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source

一、欧几里得算法(辗转相除法)

·求两个数ab的最大公约数gcdab

int gcd(int a,int b)

{

    return b==0?a:gcd(b,a%b);

}

二、拓展欧几里得算法

·求出A,B的最大公约数,且求出X,Y满足AX+BY=GCDA,B

X=Y1; Y=X1-A/B*Y1

三、中国剩余定理(孙子定理)

·求出方程组xaimod mi)(0<=i<n)的解x,其中m1m2m3,。。。,mn-1两两互质

#include<stdio.h>
int extend_gcd(int a,int b,int &x,int &y)//&x,&y引用,AX+BY=GCD(A,B)的一组解
{
    if(b == 0 )
    {
        x=1;
        y=0;
        return a;
    }
    else
    {
        int r=extend_gcd(b,a%b,x,y);
        int t=x;
        x=y;
        y=t-a/b*y;
        return r;
    }
    //返回a和b的最大公约数
}
int CRT(int a[],int m[],int n)
{
    int M=1;
    for(int i=0; i < n ; i++)   M*=m[i];
    int ret=0;
    for(int i=0 ; i < n ; i++)
    {
        int x,y;
        int tm=M/m[i];
        extend_gcd(tm,m[i],x,y);
        ret=(ret+tm*x*a[i])%M;
    }
        return (ret+M)%M;
}
int main()
{
    int p,e,i,d,x,casee=1;
    int m[3]={23,28,33};
    int a[3];
    while(scanf("%d%d%d%d",&p,&e,&i,&d))
    {
        if(p==-1&&e==-1&&i==-1&&d==-1)
            break;
        a[0]=p;a[1]=e;a[2]=i;
        int ans=CRT(a,m,3);
        ans=ans-d;
        if(ans<=0)
            ans+=21252;
        printf("Case %d: the next triple peak occurs in %d days.\n",casee,ans);
        casee++;
    }
    return 0;
}


#include<stdio.h>
int main()
{
    int p,e,i,d,x,casee=1;
    while(scanf("%d%d%d%d",&p,&e,&i,&d))
    {
        if(p==-1&&e==-1&&i==-1&&d==-1)
            break;
        x=(5544*p+14421*e+1288*i+21252)%21252;
        x=x-d;
        if(x<=0)
            x+=21252;
        printf("Case %d: the next triple peak occurs in %d days.\n",casee,x);
        casee++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值