B - Equations

B - Equations

Consider equations having the following form:

ax12+b*x22+cx32+d*x42=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0

翻译

方程
考虑具有以下形式的方程:

a * x1 ^ 2 + b * x2 ^ 2 + c * x3 ^ 2 + d * x4 ^ 2 = 0
a,b,c,d是来自区间[-50,50]的整数和它们中的任何不能为0。

这是考虑的溶液的系统(X1,X2,X3,X4),其验证方程,xi是从[-100,100]和XI的整数!= 0,任意i∈{1, 2,3,4}。

确定满足给定方程的解决方案数量。
输入
输入包含几个测试用例。每个测试用例由包含4个系数a,b,c,d的单行组成,由一个或多个空格分隔。
文件结束。
产量
对于每个测试用例,输出一行包含解决方案的数量。
样本输入
1 2 3 -4
1 1 1 1
样本输出
39088
0

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#define mem(a,b) memset(a,b,sizeof(a))

int pin[101];
int hash[2000003];

int main()
{
    int a,b,c,d;
    for(int i=1;i<=100;i++)
        pin[i]=i*i;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {
        if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
        {
            printf("0\n");
            continue;/* x*x为正数,方程成立即a,b,c,d不同号*/ 
        }
        mem(hash,0);
        for(int i=1;i<=100;i++)
            for(int j=1;j<=100;j++)
                hash[a*pin[i]+b*pin[j]+1000000]++;
        int ans=0;
        for(int i=1;i<=100;i++)
            for(int j=1;j<=100;j++)
                ans+=hash[-c*pin[i]-d*pin[j]+1000000];
        printf("%d\n",ans<<4);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值