01-复杂度2 Maximum Subsequence Sum

https://pta.patest.cn/pta/test/1342/exam/4/question/18204
Given a sequence of KKK integers { N1N_1N​1​​, N2N_2N​2​​, …, NKN_KN​K​​ }. A continuous subsequence is defined to be { NiN_iN​i​​, Ni+1N_{i+1}N​i+1​​, …, NjN_jN​j​​ } where 1≤i≤j≤K1 \le i \le j \le K1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KKK (≤10000\le 10000≤10000). The second line contains KKK numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iii and jjj (as shown by the sample case). If all the KKK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

一枚英语渣读这道题还真是吃力,数据又给的奇葩,开始一直以为是输出序列的起始地址和末地址,反复之后终究发觉是读题问题,经验主义要不得啊

方法一:在线处理,时间复杂度O(N)

#include <stdio.h>
#include <math.h>
#include <string.h>
const int MAXN=10005;
int a[MAXN];

int main()
{
    int K,Start,Last,st;
    while(~scanf("%d",&K))
    {
        for(int i=0;i<K;i++)
            scanf("%d",&a[i]);
        bool flag=false;
        int ThisSum=0,MaxSum=0,st=a[0];
        for(int i=0;i<K;i++)
        {
            ThisSum+=a[i];
            if(ThisSum>=MaxSum)
            {
                if(ThisSum!=MaxSum||(ThisSum==0&&MaxSum==0))
                {
                    MaxSum=ThisSum;
                    Start=st;
                    Last=a[i];
                    flag=true;
                }
            }
            else if(ThisSum<0)
            {
                ThisSum=0;
                st=a[i+1];
            }
        }
        if(!flag)
            printf("0 %d %d\n", a[0],a[K-1]);
        else
            printf("%d %d %d\n", MaxSum,Start,Last);
    }
    return 0;
}

仔细想了想,或许用N方的复杂度算法更容易理解一些。
方法二:时间复杂度O(N^2)

#include <stdio.h>
#include <math.h>
#include <string.h>
const int MAXN=10005;
int a[MAXN];
int main ()
{
    int K;
    while(~scanf ("%d",&K)){
        memset(a,0,sizeof(a));
    for (int i=0;i<K;i++)
        scanf ("%d",&a[i]);
    int Start,Last;
    int ThisSum=0;
    int MaxSum=-1;
    for (int i=0;i<K;i++)
    {
        ThisSum=0;
        for (int j=i;j<K;j++)
        {
            ThisSum+=a[j];
            if(ThisSum>MaxSum)
            {
                MaxSum=ThisSum;
                Start=a[i];
                Last=a[j];
            }
        }
    }
    if(MaxSum>=0)
        printf ("%d %d %d\n",MaxSum,Start,Last);
    else
        printf("0 %d %d\n",a[0],a[K-1]);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值