PAT: 01-复杂度2. Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
<pre name="code" class="cpp">#include<iostream>
using namespace std;

int main()
{
	int K, l;
	cin >> K;
	int * Pseq = new int[K];
	for(l = 0; l < K; l++)
	{
		cin >> *(Pseq+l);
	}
	int Sum=0, MaxSum=-1;//MaxSum初始值定为-1,是为了应对序列中只有负数和零的情况。
	int i = 0, j = -1, Mini = 0, Minj = 0; //j设为-1,保证j始终指向序列的当前项。
	for ( l=0; l< K; l++)
	{
		Sum += *(Pseq+l);
		j++;
		if( MaxSum < Sum)//如果有更大值,就更新子列下标。
		{
			MaxSum = Sum;
			Mini = i;
			Minj = j;
		}
		else if ( Sum <= 0)//当子列和小于或等于0,其对最大子列和已经没有贡献,可以舍去。
		{
			Sum = 0;
			i = l + 1;//使下标指向新的子列。
			j = l; 
		}
	}
	if (MaxSum == -1)//验证是否都是负数
	{
		MaxSum = 0;
		Mini = 0; 
		Minj = K-1;
	}
	cout << MaxSum << " " << *(Pseq+Mini) << " " << *(Pseq+Minj) << endl;
	delete[] Pseq;
	return 0;
}


基本思路:求取最大子列和的过程采用动态加和更新的方法,同时要记录最大子列和的下标,每当最大子列和更新的时候,就将下标更新。如果此时子列和小于或等于零,就意味着这一段子列可以从最大子列中舍去,那么就将Sum设为0,同时更新下标。最后还要判断子列是否全是负数。
 
本题测试的几个重点是:
 
 
  • 序列中只有负数和0
  • 序列中有不止一个最大子列和
  • 序列中有一些先正后负,总和等于0的子列,随后如果就是最大子列,很可能将这个子列加入最大子列
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值