hdu3709 Balanced Number

21 篇文章 0 订阅
9 篇文章 0 订阅

Balanced Number

 

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 6039    Accepted Submission(s): 2888

 

 

Problem Description

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].

 

 

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).

 

 

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

 

 

Sample Input

 

2 0 9 7604 24324

 

 

Sample Output

 

10 897

 

 

Author

GAO, Yuan

 

 

Source

2010 Asia Chengdu Regional Contest

 

 

Recommend

zhengfeng   |   We have carefully selected several similar problems for you:  3711 3715 3718 3713 3712 

 

 

 

题意:区间[l,r],求其中有多少个数n,满足以一位为支点,另外两边的数字大小乘以力矩之和相等

这样的数叫做平衡数,题目要求求出区间中平衡数的个数。

这相比最基础的数位DP有一些提高,但也不难。我们枚举以哪一位为支点,然后将两边数字大小乘以力矩和的差求出来,差为0的数即为我们所要求得到的平衡数。

剩下的方法和基础数位DP就是大同小异了。

 

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#define ll long long
using namespace std;
int digit[20];
ll dp[20][20][2005];
ll dfs(int len,int pivot,int l,int flag){  
    if(!len) return l==0; 
    if(l<0) return 0;  
    if(!flag && dp[len][pivot][l]!=-1) return dp[len][pivot][l];
    ll sum=0;
    int top=9;
    if(flag) top=digit[len];
    for(int i=0;i<=top;i++){
        int next=l;
        next+=(len-pivot)*i;
        sum+=dfs(len-1,pivot,next,flag&&i==top);
    }
    if(!flag) dp[len][pivot][l]=sum;
    return sum;
}
ll solve(ll x){
    int len=0;
    while(x){  
        digit[++len]=x%10;
        x/=10;
    }
    ll ans=0;
    for(int i=1;i<=len;i++){
        ans+=dfs(len,i,0,1);
    }
    return ans-len;
}
int main()
{  
    int T;  
    ll l,r;
    scanf("%d",&T);
    memset(dp,-1,sizeof(dp));
    while(T--){
        scanf("%I64d%I64d",&l,&r);
        printf("%I64d\n",solve(r)-solve(l-1));
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值