UVA - 10003 Cutting Sticks (区间dp)

原题:

You have to cut a wo o d stick into pieces. The most affordable company, The Analog Cutting Machinery,
Inc. (ACM), charges money according to the length of the stick b eing cut. Their pro cedure of work
requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For
example, consider a stick of length 10 meters that has to b e cut at 2, 4 and 7 meters from one end.
There are several choices. One can b e cutting first at 2, then at 4, then at 7. This leads to a price
of 10 + 8 + 6 = 24 b ecause the first stick was of 10 meters, the resulting of 8 and the last one of 6.
Another choice could b e cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =
20, which is a b etter price.
Your b oss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a p ositive
numb er l that represents the length of the stick to be cut. You can assumel < 1000. The next line will
contain the number n ( n < 50) of cuts to be made.
The next line consists of n positive numbers c i (0< c i< l) representing the places where the cuts
have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.
Sample Input
100
3
25 50 75
10
4
4 5 7 8
0
Sample Output
The minimum cutting is 200.
The minimum cutting is 22.


题意:

      一根长度为l的木棍上有n个切割点,选取不同的切割顺序使得总切割费用最小。一次的切割费用为此时木棍的长度。

思路:

      每次切割时,可看作一个新的木棍,长度为c[j]-c[i],取dp[i][j]为两端为i~切割点的木棍的最小费用,则dp[i][j]=c[j]-c[i]+min{dp[i][k]+dp[k][j] | i<k<j},c[j]-c[i]为切割当前木棍的费用,min{}为当前木棍切割后剩余两木棍继续切割所需的费用。则dp[0][n+1]为答案。注意如果木棍已是最短,无法再分割,则不需要加c[j]-c[i]。

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <deque>
#include <string>
#include <cmath>
#include <vector>
#include <utility>
#include <set>
#include <map>
#include <climits>
//#pragma comment(linker, "/STACK:1024000000,1024000000")
#define INF 2147483647
using namespace std;
typedef long long ll;
int l,n,i,j;
int c[55];
int dp[55][55];
int vis[55][55];
int dfs(int a,int b)
{
    if(vis[a][b])
        return dp[a][b];
    vis[a][b]=1;
    int m;
    if(a==b)//如果两切割点相同,即此时没有木棍
        m=0;
    else
        m=dfs(a,a+1)+dfs(a+1,b);
    for(i=a+2; i<b; i++)
        m=min(m,dfs(a,i)+dfs(i,b));
    if(b>a+1)//如果此时木棍已是最短,无法再分割,则不需要加c[j]-c[i]
        dp[a][b]=c[b]-c[a]+m;
    else
        dp[a][b]=m;
    //cout<<a<<" "<<b<<" "<<dp[a][b]<<endl;
    return dp[a][b];
}
int main()
{
    while(scanf("%d",&l)&&l)
    {
        memset(vis,0,sizeof(vis));
        memset(c,0,sizeof(c));
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        c[0]=0;
        c[n+1]=l;//0-n-1切割点为木棍两端点
        for(i=1; i<=n; i++)
            scanf("%d",&c[i]);
        int res=dfs(0,n+1);
        printf("The minimum cutting is %d.\n",res);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值