UVA10003-Cutting Sticks-区间dp

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time. It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =20, which is a better price. Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l<1000. The next line will contain the number n(n<50) of cuts to be made.The next line consists of n positive numbers ci(0<ci<l) representing the places where the cutshave to be done, given in strictly increasing order. An input case with l= 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input

100
3
25 50 75
10
4
4 5 7 8
0

Sample Output

The minimum cutting is 200.
The minimum cutting is 22.

题目大意:

给定一根长度为L的木棍,再给你n个切点,每个切点都需要切一刀,切的花费是切之前这一部分木根的长度,切的顺序不同,所需的总花费也可能不同,算出最少花费。

核心思想:

区间dp。
先枚举区间长度。
再枚举区间起点。(区间起点和区间长度可以确定区间终点)
最后枚举区间内的切点,选择花费最小的切点。(选择的策略见代码)

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int a[60],dp[60][60];
int main()
{
	int l,n;
	while(1)
	{
		scanf("%d",&l);
		if(!l)
			break;
		memset(dp,inf,sizeof(dp));
		scanf("%d",&n);
		a[0]=0;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[n+1]=l;
		for(int i=0;i<=n;i++)
			dp[i][i+1]=0;
		for(int d=2;d<=n+1;d++)//枚举区间长度 
			for(int i=0;i+d<=n+1;i++)//枚举区间起点 
				for(int j=i+1;j<i+d;j++)//枚举切点,选择最优切点更新dp值 
					dp[i][i+d]=min(dp[i][i+d],dp[i][j]+dp[j][i+d]+a[i+d]-a[i]);
		printf("The minimum cutting is %d.\n",dp[0][n+1]);
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值