HDOJ Problem - 1250 Hat's Fibonacci ( 大 数 !)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13394    Accepted Submission(s): 4504


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250

 

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

 

Input

Each line will contain an integers. Process to end of file.

 

Output

For each case, output the result in a line.

 

Sample Input

100

 

Sample Output

4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

 

Author

戴帽子的

 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1753 1865 1715 2100 1042 

 

思路:

思路就是……存入数组就可以了~  哈哈哈哈哈哈哈哈哈哈哈哈~~~

 

代码如下:

#include<iostream>
#include<cstring>
using namespace std;

int main()
{
	
	int n;
	while(cin >> n)
	{
		int Fi[5][2006]={0};
		if(n<=4)
		{
			cout << 1 << endl;
			continue;
		}	
//		memset(F,0,sizeof(x));
		Fi[1][0]=Fi[2][0]=Fi[3][0]=Fi[4][0]=1;
		
		for(int i=5;i<=n;++i)
		{
			memset(Fi[i%5],0,sizeof(Fi[i%5]));
			//每一次将Fi[i%5]清零 
			for(int j=0;j<2006;++j)
			{
				Fi[i%5][j] += (Fi[(i-1)%5][j] + Fi[(i-2)%5][j]
							+Fi[(i-3)%5][j] + Fi[(i-4)%5][j]);
				if(Fi[i%5][j]>=10)
				{
					Fi[i%5][j+1] += Fi[i%5][j]/10;
					Fi[i%5][j] = Fi[i%5][j]%10;
				} 
			}
		}
		int k=2005;
		while(Fi[n%5][k]==0)
			--k;
		while(k>=0)
		{
			cout << Fi[n%5][k];
			--k;
		} 
		cout << endl;
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值