【计算几何】POJ 2318 TOYS

POJ 2138 TOYS 【传送门】

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20891 Accepted: 9758

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题目大意:小孩比较顽皮总是把玩具胡乱丢在箱子里面,为了有效管理这些玩具,小孩子的父母就给玩具箱装了好几层隔板,然后给 m个坐标,求这m个坐标分别落在哪个分区里面,最后输出每个分区对应的玩具数。

解题思路:模板题,把每个“隔板”装到一个数组里面,然后进行点的判断时候,遍历隔板数组,如果叉积小于0在该隔板坐标对应分区++、反之继续向下判断。最后输出每个分区的数目。

AC代码:(前面都是模板,懒得删除了……)

#include<iostream>
#include<complex>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
#define eps 1e-9
#define inf 99999999
typedef long long ll;
struct Point{
	double x,y;
	Point(double x=0,double y=0):x(x),y(y){}
}; 
typedef Point Vector;

Vector operator + (Vector A,Vector B){return Vector(A.x+B.x,A.y+B.y);}
Vector operator - (Vector A,Vector B){return Vector(A.x-B.x,A.y-B.y);}
Vector operator * (Vector A,double p){return Vector(A.x*p,A.y*p);}
Vector operator / (Vector A,double p){return Vector(A.x/p,A.y/p);}

bool operator < (const Point& a,const Point& b)
{
	return a.x < b.x || (a.x==b.x && a.y<b.y);
}

int dcmp(double x)
{
	if(fabs(x)<eps) 
		return 0;
	else
		return x<0?-1:1;
}

bool operator == (const Point& a,const Point& b)
{
	return dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)==0;
}

struct Line{
	Point v,p;
	//v up\ p down
	//Line(Point v,Point p):v(v),p(p){}
	//Point point(double t){
	//	return v+(p-v)*t;
	//}
};

//点积
double Dot(Vector A,Vector B){ return A.x*B.x+A.y*B.y;}
double Length(Vector A){return sqrt(Dot(A,A));}
double Angle(Vector A,Vector B){return acos(Dot(A,B)/Length(A)/Length(B)); }
 
//叉积
double Cross(Vector A,Vector B){return A.x*B.y-A.y*B.x;}
double Area2(Point A,Point B,Point C){return Cross(B-A,C-A);}

//向量 旋转,rad是弧度
Vector Rotate(Vector A,double rad)
{
	return Vector(A.x*cos(rad)-A.y*sin(rad),A.x*sin(rad)+A.y*cos(rad));
}
//计算单位法线
Vector Normal(Vector A)
{
	double L=Length(A);
	return Vector(-A.y/L,A.x/L);
} 

//判断折线bc是不是向ab的逆时针方向转
bool ToLeftTest(Point a,Point b,Point c)
{
	return Cross(b-a,c-b)>0;
 } 
 
//直线交点
Point GetLineIntersection(Point P,Vector v,Point Q,Vector w)
{
	Vector u=P-Q;
	//确保Cross(v,w)!=0
	double t=Cross(w,u)/Cross(v,w);
	return P+v*t; 
}

//点到直线距离
double DistanceToLine(Point P,Point A,Point B)
{
	Vector v1=B-A,v2=P-A;
	return fabs(Cross(v1,v2))/Length(v1);
	//如果不取绝对值,得到的是有向距离	
} 

//点到线段的距离
double DistanceToSegment(Point P,Point A,Point B)
{
	if(A==B) return Length(P-A);
	Vector v1=B-A,v2=P-A,v3=P-B;
	if(dcmp(Dot(v1,v2))<0)	return Length(v2);
	else if(dcmp(Dot(v1,v3))>0)	return Length(v3);
	else return fabs(Cross(v1,v2))/Length(v1);	
}  

//点在直线上的投影
Point GetLineProjection(Point P,Point A,Point B)
{
	Vector v=B-A;
	return A+v*(Dot(v,P-A)/Dot(v,v));
} 

//点是否在线段上
bool OnSegment(Point p,Point a1,Point a2)
{
	return dcmp(Cross(a1-p,a2-p))==0&&dcmp(Dot(a1-p,a2-p))<0;
 } 

//线段相交判定
bool SegmentProperIntersection(Point a1,Point a2,Point b1,Point b2){
	double c1=Cross(a2-a1,b1-a1),c2=Cross(a2-a1,b2-a1),
		   c3=Cross(b2-b1,a1-b1),c4=Cross(b2-b1,a2-b1);
	return dcmp(c1)*dcmp(c2)<0 && dcmp(c3)*dcmp(c4)<0;	
} 

//允许在线段端点相交
bool SegmentProperIntersection_duan(Point a1,Point a2,Point b1,Point b2)
{
	double c1=Cross(a2-a1,b1-a1),c2=Cross(a2-a1,b2-a1),
		   c3=Cross(b2-b1,a1-b1),c4=Cross(b2-b1,a2-b1);
	//if判断控制是否允许线段在端点处相交,根据需要添加
	if(!dcmp(c1)||!dcmp(c2)||!dcmp(c3)||!dcmp(c4))
	{
		bool f1=OnSegment(b1,a1,a2);
		bool f2=OnSegment(b2,a1,a2);
		bool f3=OnSegment(a1,b1,b2);
		bool f4=OnSegment(a2,b1,b2);
		bool f=(f1|f2|f3|f4);
		return f;	
	}	   
	return (dcmp(c1)*dcmp(c2)<0&&dcmp(c3)*dcmp(c4)<0);
} 

//多边形有向面积
//p为端点集合,n为端点个数 
double PolygonArea(Point* p,int n)
{
	double s=0;
	for(int i=0;i<n-1;i++)
		s+=Cross(p[i]-p[0],p[i+1]-p[0]);
	return s/2;
} 

//判断点在多边形内
int isPointPolygon(Point p,vector<Point> poly)
{
	int wn=0;
	int n=poly.size();
	for(int i=0;i<n;i++)
	{
		if(OnSegment(p,poly[i],poly[(i+1)%n]))
			return -1;
		int k=dcmp(Cross(poly[(i+1)%n]-poly[i],p-poly[i]));
		int d1=dcmp(poly[i].y-p.y);
		int d2=dcmp(poly[(i+1)%n].y-p.y);
		if(k>0&&d1<=0&&d2>0) wn++;
		if(k<0&&d2<=0&&d1>0) wn--;
	}	
	if(wn!=0)
		return 1;
	return 0;
} 
//-------------------------------------------------------------------------------------------------------
#define MAXN 5005
Line L[MAXN];
int ans[MAXN];

int main()
{
	int n,m;
	double x1,y1,x2,y2;
	while(cin >> n)
	{
		if(n==0)
			break;
		memset(ans,0,sizeof(ans));
		cin >> m >> x1 >> y1 >> x2 >> y2;
		Point a,b;
		a.x=x1,a.y=y2;
		b.x=x1,b.y=y1;
		L[0].p=a,L[0].v=b;		
		double up,down;
		for(int i=1;i<=n;i++)
		{
			cin >> up >> down;
			a.x=up,a.y=y1;
			b.x=down,b.y=y2;
			L[i].v=a,L[i].p=b;		
		}
		a.x=x2,a.y=y1;
		b.x=x2,b.y=y2;
		L[n+1].v=a,L[n+1].p=b;
		double x,y;
		while(m--)
		{
			cin >> x >> y;
			a.x=x,a.y=y;
			for(int i=0;i<=n+1;i++)
			{
				if(Cross(a-L[i].v,L[i].v-L[i].p)>0)
					continue;
				else
				{
					ans[i-1]++;
					break;
				}
					
			}
		}
		for(int i=0;i<=n;i++)
			cout << i << ": " << ans[i] << endl;
		cout << endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值