【强连通】UVA 315 Network

UVA 315 Network 【传送门】

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just ‘0’. The last block has only one line with N = 0.

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

求割点,套用tarjan模板:

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<queue>
#include<map>
#include<set> 
#include<algorithm>
using namespace std;
#define lowbit(x) (x&-x)
#define mem(a,b) memset(a,b,sizeof(a))
#define eps 1e-9
#define INF 999999
#define MAXN 105
//struct edge{
//	int to;
//	//int val;		//如果有权值可以添加 
//};
//int next[MAXN]; 
vector<int> G[MAXN];
int dfn[MAXN],low[MAXN];
bool instack[MAXN];
set<int> ans;		//存储割点 
stack<int> s;				
int timing;				//时间戳 
int color[MAXN];		//代表当前结点所属第几个scc 
int colornum[MAXN];		//代表第某个scc有几个结点 
int cnt;				//scc个数 
int V,E;				 

void init()
{
	for(int i=0;i<=V;i++)
		G[i].clear();
	ans.clear();
	mem(dfn,0);
	mem(color,0);
	mem(colornum,0);
	mem(instack,false);
	mem(low,0);
	timing=cnt=0;
}

割点 
void tarjan_Point(int u,int rt)
{
	++timing;
	low[u]=dfn[u]=timing;
	int child=0; 
	for(int i=0;i<G[u].size();i++)
	{
		int v=G[u][i];
		if(dfn[v]==0)
		{
			child++;
			tarjan_Point(v,rt);
			low[u]=min(low[u],low[v]);
			if(u!=rt && low[v]>=dfn[u]){
				ans.insert(u);
			}
		}
		low[u]=min(low[u],dfn[v]);
	}		
	if(child>=2&&u==rt){
		ans.insert(u);
	}
}

int main()
{
	
	while(cin >> V && V){
		init();
		int a;
		while(cin >> a && a){
			int b;
			while(getchar()!='\n'){
				cin >> b;
				G[a].push_back(b);
				G[b].push_back(a);
			}
		}
		for(int i=1;i<=V;i++)
			if(dfn[i]==0)
				tarjan_Point(i,i);
		
		cout << ans.size() << endl;
		
	}
	
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值