二分法:解方程



F - Strange fuction
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input

    
    
2 100 200
 

Sample Output

  
  
-74.4291 -178.8534
 
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <iostream>

using namespace std;

double dao(double x){
    return 42 * pow(x, 6)+48*pow(x, 5)+21 * pow(x, 2) + 10* x ;
}

double ans(double x, double y){
    return 6 * pow(x, 7)+8*pow(x, 6)+7*pow(x, 3)+5*pow(x,2)-y*x;
}

int main(){
    int n;
    double y;
    double x;
    double mid;
    cin >> n;
    while(n --){
        cin >> y;
        	double	f=0.0;
		double l=100.0;
		if(dao(f)-y>=0)
		{
			printf("%.4lf\n",ans(f,y));
			continue;
		}
		else if(dao(l)-y<=0)
		{
			printf("%.4lf\n",ans(l,y));
			continue;
		}
		while(l-f>1e-6)
		{
			mid=(f+l)/2;
			if(dao(mid)-y>=0)
				l=mid;
			else
				f=mid;
		}
		printf("%.4lf\n",ans((f+l)/2,y));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值