DP:Divide Chocolate

Divide Chocolate

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 706    Accepted Submission(s): 325


Problem Description
It is well known that claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.

To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.
 

Input
First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts claire wants to divide it into.
 

Output
For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line.&#160;
 

Sample Input
  
  
2 2 1 5 2
 

Sample Output
  
  
1 45

直接DP,状态表示 f[i][0][j]:前i行已经出现了j部分且第i行的两个格子属于同一部分的方法数,

f[i][1][j]:前i行已经出现了j部分且第i行的两个格子属于不同部分的方法数

初始条件 f[1][0][1]=f[1][1][2]=1

状态转移方程如下:

                   

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

#define mod 100000007
int f[1005][2][2010]; //i代表列数;
                      // 0代表第i行两个子在一起,1代表不在一起
                      //j代表到第i行有j块
int ini(){
    int i, j, k;
    memset(f,0,sizeof(f));
    f[1][0][1]=1;
    f[1][1][2]=1;
    for(i=2;i<=1001;i++){//代表每列的意思
        for(j=1;j<=2*i;j++){ //循环到2*i的原因是最多2*i块
            f[i][0][j]=(f[i-1][0][j]+f[i-1][1][j]*2+f[i-1][0][j-1]+f[i-1][1][j-1]) % 100000007;
            f[i][1][j]=(f[i-1][0][j-1]*2+f[i-1][1][j]+f[i-1][1][j-1]*2)% 100000007;
            if(j>=2)f[i][1][j]+=(f[i-1][0][j-2]+f[i-1][1][j-2]) % 100000007;
        }
    }
}

int main(){
    int c, n, k;
    cin >> c;
    ini();
    while( c --)
    {
        cin >> n >> k;
        cout<<( f[n][0][k] + f[n][1][k] ) % 100000007 << endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值